1. This change needs more explanation of its rationale. A strict bi-directional relation exists between StateManager and PersistenceCapable which is good for overall health of the software. This method seems to weaken that contract.
2. At present, nothing calls it. It is better to add new methods "for extensibility" as and when they are needed.
3. The method should be renamed setPersistenceCapable(), if it has to exist.
4. Consider rolling back this change, for now.