OpenJPA
  1. OpenJPA
  2. OPENJPA-1552

Enable EntityManager to perform property QueryImpl creation by its subclass

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-beta
    • Fix Version/s: 2.0.0-beta3
    • Component/s: kernel
    • Labels:
      None

      Description

      Ran into the following exception when derived OpenJPA provider is used to create multiple query of the same JPQL statement.

      openjpa.prepared.SQL

      org.apache.openjpa.persistence.PersistenceException: openjpa.prepared.SQL
      at org.apache.openjpa.kernel.BrokerImpl.newQuery(BrokerImpl.java:3661)
      at org.apache.openjpa.kernel.DelegatingBroker.newQuery(DelegatingBroker.java:1251)
      at org.apache.openjpa.persistence.EntityManagerImpl.createQuery(EntityManagerImpl.java:966)
      at com.ibm.ws.persistence.EntityManagerImpl.createQuery(EntityManagerImpl.java:102)
      at com.ibm.ws.persistence.EntityManagerImpl.createQuery(EntityManagerImpl.java:81)
      at com.ibm.ws.persistence.EntityManagerImpl.createQuery(EntityManagerImpl.java:29)
      at com.ibm.ws.query.pdq.tests.JsePdqCrudTest.setUp(JsePdqCrudTest.java:167)

        Activity

        Albert Lee added a comment -

        It turns out the problem is not in OpenJPA. It is caused by a derived provider's StoreManager class not supporting QueryLanguages.LANG_PREPARED_SQL.

        I shall change this JIRA to enable EntityManagerImpl to support proper QueryImpl creation for its subclass.


          People

          • Assignee:
            Albert Lee
            Reporter:
            Albert Lee
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development