Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-1527

AssociationOverride does not work when applying to the map key of the element collection via orm.xml

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.0.0-beta
    • Component/s: jpa
    • Labels:
      None

      Activity

      faywang Fay Wang added a comment -

      The cause of the problem is that the key of the map can be embeddable, which can have associationOverride specified in the orm.xml. However, currently openjpa only handles the associationOverride on the element in an element collection, which can be a map or a collection.

      The fix is to loop through the remaining _deferredMappings in the XMLPersistenceMappingParser (which does not have covered by the _embeddables), and process the associationOverride information stored in it.

      to_rowe Thomas O Rowe added a comment -

      Fix verified on IBM SE6 on Linux AMD64 running JSE, web, and EJB scenarios.


        People

        • Assignee:
          faywang Fay Wang
          Reporter:
          faywang Fay Wang
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development