Uploaded image for project: 'OpenJPA'
  1. OpenJPA
  2. OPENJPA-1356

Use maven-enforcer-plugin to verify proper Java and Maven levels

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.3, 1.1.0, 1.2.1, 2.0.0-M3
    • Fix Version/s: 1.3.0, 2.0.0-beta
    • Component/s: build / infrastructure
    • Labels:
      None

      Description

      Use the maven-enforcer-plugin to verify that builds are being run with:
      maven >= 2.0.5
      1.3.x builds are run with:
      Java == 1.5.x
      trunk builds are run with:
      Java >= 1.5.x

        Attachments

          Activity

            People

            • Assignee:
              drwoods Donald Woods
              Reporter:
              drwoods Donald Woods
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: