OpenJPA
  1. OpenJPA
  2. OPENJPA-135

join fetch not returning duplicate references which not conforming to ejb3.0 spec

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 1.0.2
    • Component/s: jpa
    • Labels:
      None

      Description

      In the description in EJB 3.0 JPA spec, section 4.4.5.3, the following query example
      SELECT d
      FROM Department d LEFT JOIN FETCH d.employees
      WHERE d.deptno = 1

      The spec says this query returns 5 references to the department 1 entity if department 1 has 5 employees.

      The same query running with openjpa code, it returns only 1 reference to department 1 entity.

        Issue Links

          Activity

          Craig L Russell added a comment -

          Would it be possible for you to attach a simple test case to this issue? Thanks.

          Kevin Sutter added a comment -

          Now that Catalina is a full-fledged committer, maybe she can help determine the fate of this Issue...

          This is quite an old Issue. We should determine whether this problem even exists any longer. And, if so, can we get it resolved before the 1.0.0 deadline or should it be moved out? I'm hoping Catalina can help figure out the right course of action.

          Thanks,
          Kevin

          Marc Prud'hommeaux added a comment -

          Bumping to release 1.0.1 since 1.0.0 is being released.

          Albert Lee added a comment -

          Defer to next release.

          Patrick Linskey added a comment -

          Seems to work in 1.0.2 already.


            People

            • Assignee:
              Catalina Wei
              Reporter:
              Catalina Wei
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development