Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.1.0
    • Component/s: jpa
    • Labels:
      None
    • Patch Info:
      Patch Available

      Activity

      Tim McConnell created issue -
      Heath Thomann made changes -
      Field Original Value New Value
      Assignee Tim McConnell [ mcconne ] Heath Thomann [ jpaheath ]
      Heath Thomann added a comment -

      Same issue as described in parent JIRA OPENJPA-1300 and as further described in OPENJPA-1319. Providing patch OPENJPA-1314-trunk.patch. I added code to safe guard against the potential of nulls being used in the hashCode and/or equals methods, thus avoiding any potential NullPointerExceptions.

      Thanks,

      Heath

      Heath Thomann made changes -
      Attachment OPENJPA-1314-trunk.patch [ 12458110 ]
      Donald Woods made changes -
      Fix Version/s 2.1.0 [ 12314542 ]
      Affects Version/s 2.0.0 [ 12314019 ]
      Patch Info [Patch Available]
      Priority Major [ 3 ] Minor [ 4 ]
      Component/s jpa [ 12311304 ]
      Donald Woods added a comment -

      r1027984 in trunk

      Donald Woods made changes -
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Michael Dick added a comment -

      Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

      Michael Dick made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Resolved Resolved
      402d 13h 15m 1 Donald Woods 27/Oct/10 15:51
      Resolved Resolved Closed Closed
      78d 1h 54m 1 Michael Dick 13/Jan/11 16:45

        People

        • Assignee:
          Heath Thomann
          Reporter:
          Tim McConnell
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development