Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.3, 1.2.1
    • Fix Version/s: 1.0.4, 1.2.2, 1.3.0, 2.0.0-beta
    • Component/s: None
    • Labels:
      None

      Description

      The TestCase for DataCache included / excluded types relies on a NativeQuery to drop database tables at the end of the test. This fails with some versions of the MySQL JDBC driver.

      The exception from the testcase looks like this :
      <openjpa-1.0.4-SNAPSHOT-rexported nonfatal general error> org.apache.openjpa.persistence.PersistenceException: Unable to retrieve metadata for procedure.
      at org.apache.openjpa.jdbc.sql.DBDictionary.newStoreException(DBDictionary.java:3964)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:97)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:83)
      at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore(SQLExceptions.java:59)
      at org.apache.openjpa.jdbc.kernel.SQLStoreQuery$SQLExecutor.executeUpdate(SQLStoreQuery.java:242)

      <snip>
      Caused by: java.sql.SQLException: Unable to retrieve metadata for procedure.
      at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:910)
      at com.mysql.jdbc.CallableStatement.extractProcedureName(CallableStatement.java:857)
      at com.mysql.jdbc.CallableStatement.determineParameterTypes(CallableStatement.java:692)
      at com.mysql.jdbc.CallableStatement.<init>(CallableStatement.java:513)
      at com.mysql.jdbc.Connection.parseCallableStatement(Connection.java:4422)
      at com.mysql.jdbc.Connection.prepareCall(Connection.java:4496)
      at com.mysql.jdbc.Connection.prepareCall(Connection.java:4470)
      at org.apache.commons.dbcp.DelegatingConnection.prepareCall(DelegatingConnection.java:212)

      Upgrading to a more recent version of the MySQL driver resolves these issues and allows the testcase to pass.

        Issue Links

          Activity

          Michael Dick created issue -
          Milosz Tylenda made changes -
          Field Original Value New Value
          Link This issue relates to OPENJPA-774 [ OPENJPA-774 ]
          Milosz Tylenda added a comment - - edited

          This is probably the same issue as in OPENJPA-774 - we use prepareCall instead of prepareStatement.

          Michael Dick added a comment -

          Hi Milosz,

          That's another way to address the issue I suppose. Since the 5.1.6 driver allows us to use prepareCall without hitting the issue (at least on Linux), I'm content to use that instead of making a code change though.

          That would explain why I didn't see the problem with trunk / 1.3.x though.

          Michael Dick made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Michael Dick made changes -
          Fix Version/s 1.0.4 [ 12313301 ]
          Fix Version/s 1.2.2 [ 12313681 ]
          Fix Version/s 1.3.0 [ 12313326 ]
          Fix Version/s 2.0.0 [ 12314019 ]
          Donald Woods made changes -
          Fix Version/s 2.0.0-beta [ 12314149 ]
          Fix Version/s 2.0.0 [ 12314019 ]

            People

            • Assignee:
              Michael Dick
              Reporter:
              Michael Dick
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development