Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.2, 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: jpa
    • Labels:
      None
    • Patch Info:
      Patch Available

      Activity

      Donald Woods made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Donald Woods made changes -
      Status In Progress [ 3 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Donald Woods made changes -
      Attachment OPENJPA-1179.patch [ 12441407 ]
      Donald Woods added a comment -

      Updated testcase and doc updates for 2.0.0.

      Donald Woods made changes -
      Status Open [ 1 ] In Progress [ 3 ]
      Donald Woods made changes -
      Assignee Tim McConnell [ mcconne ] Donald Woods [ drwoods ]
      Donald Woods added a comment -

      testMultiEMCachingAll(org.apache.openjpa.persistence.compat.TestQuerySQLCache) Time elapsed: 0.058 sec <<< ERROR!
      javax.persistence.PersistenceException: Explicit persistence provider error(s) occurred for "test" after trying the following discovered implementations: org.apache.openjpa.persistence.PersistenceProviderImpl from provider: org.apache.openjpa.persistence.PersistenceProviderImpl
      . . .
      Caused by: <openjpa-2.1.0-SNAPSHOT-r422266:932643M fatal general error> org.apache.openjpa.persistence.PersistenceException: There was an error when invoking the static newInstance method on the named factory class "org.apache.openjpa.jdbc.kernel.JDBCBrokerFactory". See the nested exception for details.
      . . .
      Caused by: org.apache.openjpa.lib.util.ParseException: There was an error while setting up the configuration option "jdbc.QuerySQLCache", and it was set to "all". All possible values for this setting are: [true, org.apache.openjpa.jdbc.kernel.PreparedQueryCacheImpl, false, null].

      Tim McConnell made changes -
      Attachment OPENJPA-1179-TESTCASE.patch [ 12413775 ]
      Tim McConnell added a comment -

      Attaching patch with a testcase which demonstrates a failure in trunk (that works fine for JPA 1.2.x) when using various permutations of openjpa.jdbc.QuerySQLCache settings that were valid in JPA 1.2 but may not be valid in JPA 2.0.

      Tim McConnell made changes -
      Field Original Value New Value
      Patch Info [Patch Available]
      Tim McConnell created issue -

        People

        • Assignee:
          Donald Woods
          Reporter:
          Tim McConnell
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development