Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-7779

Update wiki Eclipse pages regarding Gradle

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: Confluence
    • Labels:
      None

      Description

      I wanted to update the 2 wiki Eclipse pages regarding Gradle. But so far got some issues in my environment (still Windows 7).

      I use both Eclipse Luna and Mars (Mars at 98%). Luna does not support Gradle.

      First I must say my Mars instance works perfectly, but for few months I'm unable to update. I did not try yet to create another Mars instance because I guess it will anyway screws its update mechanism later :/

      Mars comes with the embedded "Gradle Buildship" plugin, I have the 1.0.5 version from 2015-09-22. I found this tuto http://www.vogella.com/tutorials/EclipseGradle/article.html (with a 6/7 clone/redundant section).

      Few remarks: I see no Gradle context menu entrie, maybe due to my unability to update Mars, so I'm unable to "add Gradle support to existing Eclipse project ". So I created a Gradle "trunk" side project following , but, though all work well in command line, in Eclipse building with Gradle does not work. I always get (see compile.error)

      Of course I tried (4th) to install Eclipse Neon, to no avail, so far the best I got (at least I eventually got something) is in neon.error

      I'll continue later...

      1. compile.error
        21 kB
        Jacques Le Roux
      2. Image 007.png
        9 kB
        Jacques Le Roux
      3. neon.error
        22 kB
        Jacques Le Roux
      4. OFBIZ-7779.patch
        15 kB
        Taher Alkhateeb
      5. OFBIZ-7779.patch
        2 kB
        Taher Alkhateeb

        Issue Links

          Activity

          jacques.le.roux Jacques Le Roux added a comment -

          OK Got Neon working starting from https://spring.io/tools/eclipse?JAVA-WIN64

          jacques.le.roux Jacques Le Roux added a comment -

          Updating got this after 1/2 H

          Some sites could not be found.  See the error log for more detail.
          Unable to read repository at http://download.eclipse.org/eclipse/updates/4.6.
          Unable to read repository at http://download.eclipse.org/eclipse/updates/4.6/R-4.6-201606061100/content.jar.
          Connection reset
          Unable to read repository at http://download.eclipse.org/releases/neon.
          Unable to read repository at http://download.eclipse.org/releases/neon/201606221000/content.xml.xz.
          Read timed out
          

          No wonder people are turning to IntelliJ after turning to Mac OS. Anyway let's see

          jacques.le.roux Jacques Le Roux added a comment -

          OK after setting Neon, I still have the 2 same issues with "Gradle Buildship" plugin

          1. import-an-existing-gradle-project as explained in tuto
            Loading Gradle project preview failed due to an error in the referenced Gradle build.
            Could not fetch model of type 'GradleBuild' using Gradle distribution 'https://services.gradle.org/distributions/gradle-2.13-bin.zip'.
            Settings file 'C:\projectASF-Mars\ofbiz\settings.gradle' line: 20
            A problem occurred evaluating settings 'ofbiz'.
            C:\Neon\framework\component-load.xml (Le chemin d’accès spécifié est introuvable)
            org.gradle.tooling.BuildException: Could not fetch model of type 'GradleBuild' using Gradle distribution 'https://services.gradle.org/distributions/gradle-2.13-bin.zip'.
            	at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(ExceptionTransformer.java:51)
            	at org.gradle.tooling.internal.consumer.ExceptionTransformer.transform(ExceptionTransformer.java:29)
            	at org.gradle.tooling.internal.consumer.ResultHandlerAdapter.onFailure(ResultHandlerAdapter.java:41)
            	at org.gradle.tooling.internal.consumer.async.DefaultAsyncConsumerActionExecutor$1$1.run(DefaultAsyncConsumerActionExecutor.java:57)
            	at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54)
            	at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40)
            	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            	at java.lang.Thread.run(Unknown Source)
            	at org.gradle.tooling.internal.consumer.BlockingResultHandler.getResult(BlockingResultHandler.java:46)
            	at org.gradle.tooling.internal.consumer.DefaultModelBuilder.get(DefaultModelBuilder.java:51)
            	at com.gradleware.tooling.toolingclient.internal.DefaultToolingClient.executeAndWait(DefaultToolingClient.java:128)
            	at com.gradleware.tooling.toolingclient.internal.DefaultModelRequest.executeAndWait(DefaultModelRequest.java:79)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository$1.get(BaseModelRepository.java:95)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository.executeAndWait(BaseModelRepository.java:161)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository.access$000(BaseModelRepository.java:41)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository$2.call(BaseModelRepository.java:120)
            	at com.google.common.cache.LocalCache$LocalManualCache$1.load(LocalCache.java:4724)
            	at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3522)
            	at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2315)
            	at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2278)
            	at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2193)
            	at com.google.common.cache.LocalCache.get(LocalCache.java:3932)
            	at com.google.common.cache.LocalCache$LocalManualCache.get(LocalCache.java:4721)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository.getFromCache(BaseModelRepository.java:136)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository.executeRequest(BaseModelRepository.java:116)
            	at com.gradleware.tooling.toolingmodel.repository.internal.BaseModelRepository.executeRequest(BaseModelRepository.java:88)
            	at com.gradleware.tooling.toolingmodel.repository.internal.DefaultSingleBuildModelRepository.fetchGradleBuildStructure(DefaultSingleBuildModelRepository.java:130)
            	at org.eclipse.buildship.core.projectimport.ProjectPreviewJob.fetchGradleBuildStructure(ProjectPreviewJob.java:94)
            	at org.eclipse.buildship.core.projectimport.ProjectPreviewJob.runToolingApiJobInWorkspace(ProjectPreviewJob.java:83)
            	at org.eclipse.buildship.core.util.progress.ToolingApiWorkspaceJob$1.run(ToolingApiWorkspaceJob.java:79)
            	at org.eclipse.buildship.core.util.progress.ToolingApiInvoker.invoke(ToolingApiInvoker.java:63)
            	at org.eclipse.buildship.core.util.progress.ToolingApiWorkspaceJob.runInWorkspace(ToolingApiWorkspaceJob.java:76)
            	at org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:39)
            	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
            Caused by: org.gradle.internal.exceptions.LocationAwareException: Settings file 'C:\projectASF-Mars\ofbiz\settings.gradle' line: 20
            A problem occurred evaluating settings 'ofbiz'.
            	at org.gradle.initialization.DefaultExceptionAnalyser.transform(DefaultExceptionAnalyser.java:74)
            	at org.gradle.initialization.MultipleBuildFailuresExceptionAnalyser.transform(MultipleBuildFailuresExceptionAnalyser.java:47)
            	at org.gradle.initialization.StackTraceSanitizingExceptionAnalyser.transform(StackTraceSanitizingExceptionAnalyser.java:30)
            	at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:101)
            	at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:93)
            	at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:90)
            	at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:62)
            	at org.gradle.initialization.DefaultGradleLauncher.doBuild(DefaultGradleLauncher.java:93)
            	at org.gradle.initialization.DefaultGradleLauncher.getBuildAnalysis(DefaultGradleLauncher.java:87)
            	at org.gradle.launcher.exec.InProcessBuildActionExecuter$DefaultBuildController.configure(InProcessBuildActionExecuter.java:102)
            	at org.gradle.tooling.internal.provider.runner.BuildModelActionRunner.run(BuildModelActionRunner.java:48)
            	at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35)
            	at org.gradle.tooling.internal.provider.runner.SubscribableBuildActionRunner.run(SubscribableBuildActionRunner.java:58)
            	at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35)
            	at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:43)
            	at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:28)
            	at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:81)
            	at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:46)
            	at org.gradle.launcher.daemon.server.exec.ExecuteBuild.doBuild(ExecuteBuild.java:52)
            	at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.WatchForDisconnection.execute(WatchForDisconnection.java:37)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.ResetDeprecationLogger.execute(ResetDeprecationLogger.java:26)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.RequestStopIfSingleUsedDaemon.execute(RequestStopIfSingleUsedDaemon.java:34)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.ForwardClientInput$2.call(ForwardClientInput.java:74)
            	at org.gradle.launcher.daemon.server.exec.ForwardClientInput$2.call(ForwardClientInput.java:72)
            	at org.gradle.util.Swapper.swap(Swapper.java:38)
            	at org.gradle.launcher.daemon.server.exec.ForwardClientInput.execute(ForwardClientInput.java:72)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.health.DaemonHealthTracker.execute(DaemonHealthTracker.java:47)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.LogToClient.doBuild(LogToClient.java:60)
            	at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.EstablishBuildEnvironment.doBuild(EstablishBuildEnvironment.java:72)
            	at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.health.HintGCAfterBuild.execute(HintGCAfterBuild.java:41)
            	at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
            	at org.gradle.launcher.daemon.server.exec.StartBuildOrRespondWithBusy$1.run(StartBuildOrRespondWithBusy.java:50)
            	at org.gradle.launcher.daemon.server.DaemonStateCoordinator$1.run(DaemonStateCoordinator.java:246)
            	at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54)
            	at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40)
            Caused by: org.gradle.api.GradleScriptException: A problem occurred evaluating settings 'ofbiz'.
            	at org.gradle.groovy.scripts.internal.DefaultScriptRunnerFactory$ScriptRunnerImpl.run(DefaultScriptRunnerFactory.java:93)
            	at org.gradle.configuration.DefaultScriptPluginFactory$ScriptPluginImpl$2.run(DefaultScriptPluginFactory.java:157)
            	at org.gradle.configuration.DefaultScriptTarget.addConfiguration(DefaultScriptTarget.java:69)
            	at org.gradle.configuration.DefaultScriptPluginFactory$ScriptPluginImpl.apply(DefaultScriptPluginFactory.java:162)
            	at org.gradle.initialization.ScriptEvaluatingSettingsProcessor.applySettingsScript(ScriptEvaluatingSettingsProcessor.java:72)
            	at org.gradle.initialization.ScriptEvaluatingSettingsProcessor.process(ScriptEvaluatingSettingsProcessor.java:62)
            	at org.gradle.initialization.PropertiesLoadingSettingsProcessor.process(PropertiesLoadingSettingsProcessor.java:37)
            	at org.gradle.initialization.NotifyingSettingsProcessor$1.create(NotifyingSettingsProcessor.java:42)
            	at org.gradle.initialization.NotifyingSettingsProcessor$1.create(NotifyingSettingsProcessor.java:39)
            	at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:90)
            	at org.gradle.initialization.NotifyingSettingsProcessor.process(NotifyingSettingsProcessor.java:39)
            	at org.gradle.initialization.SettingsHandler.findSettingsAndLoadIfAppropriate(SettingsHandler.java:90)
            	at org.gradle.initialization.SettingsHandler.findAndLoadSettings(SettingsHandler.java:47)
            	at org.gradle.initialization.NotifyingSettingsLoader.findAndLoadSettings(NotifyingSettingsLoader.java:33)
            	at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(DefaultGradleLauncher.java:119)
            	at org.gradle.initialization.DefaultGradleLauncher.access$200(DefaultGradleLauncher.java:32)
            	at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:99)
            	... 42 more
            Caused by: java.io.FileNotFoundException: C:\Neon\framework\component-load.xml (Le chemin d’accès spécifié est introuvable)
            	at com.sun.org.apache.xerces.internal.impl.XMLEntityManager.setupCurrentEntity(Unknown Source)
            	at com.sun.org.apache.xerces.internal.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
            	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
            	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
            	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
            	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
            	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
            	at settings_rxcldu4lexpb2pwubn0mmfsl.iterateOverActiveComponents(C:\projectASF-Mars\ofbiz\settings.gradle:20)
            	at settings_rxcldu4lexpb2pwubn0mmfsl$iterateOverActiveComponents.callCurrent(Unknown Source)
            	at settings_rxcldu4lexpb2pwubn0mmfsl.run(C:\projectASF-Mars\ofbiz\settings.gradle:41)
            	at org.gradle.groovy.scripts.internal.DefaultScriptRunnerFactory$ScriptRunnerImpl.run(DefaultScriptRunnerFactory.java:91)
            	... 58 more
            

            Of course https://services.gradle.org/distributions/gradle-2.13-bin.zip is not a problem at all, so... I give up for now (BTW I got that working on Mars)

          2. add-gradle-support-to-existing-eclipse-project as explained in tuto I see not "Add Gradle Nature" button.

          So I for now give up hope to have Gradle plugin delivers the same than Ant plugin was in Eclipse. Not a blocker, we can expect it will improve...

          taher Taher Alkhateeb added a comment -

          Hi Jacques,

          So I have done multiple improvements to the eclipse plugin. These improvements achieve the following
          1- Fix some path issues for folders
          2- Remove unnecessary config source directories

          I got eclipse working correctly with Gradle by applying the following:

          1- create a normal java project
          2- create a run/debug configuration of type gradle
          3- run it

          That's it.

          taher Taher Alkhateeb added a comment -

          Attaching a more improved version that fixes the path issues everywhere

          taher Taher Alkhateeb added a comment -

          Hmmmm strange. I did not know eclipse behaves differently on different platforms as it works fine with Gradle on my Linux machine.

          I'll try to reproduce on windows on virtualbox to see whats up

          Either way this patch improves things so I will commit it

          jacques.le.roux Jacques Le Roux added a comment - - edited

          Thanks Taher,

          It's already much better

          I still have few issues in the "Problems" view, for each component:

          Description Resource Path Location Type
          Project 'ofbiz' is missing required source folder: '//applications/accounting' ofbiz   Build path Build Path Problem
          ... ofbiz   Build path Build Path Problem
          The project cannot be built until build path errors are resolved ofbiz   Unknown Java Problem

          But it does not prevent to use the Gradle tasks and I just begin to prefer Neon+Gradle over Mars+Ant

          This is unrelated (only 49 come from Gradle) and amazing

          I will begin to amend the wiki pages...

          jacques.le.roux Jacques Le Roux added a comment -

          Windows is a vicious beast

          taher Taher Alkhateeb added a comment -

          What I thought would be a quick fix took me a while and I uncovered a lot of problems in the build script.

          Anyway, now it is working perfectly on both Windows and Linux after the commit r1752658 with all tests passing.

          Cheers

          jacques.le.roux Jacques Le Roux added a comment -

          Thanks Taher
          All is totally clean from Gradle path issue at my end, congrats!
          It must have been a tedious work when you did not see this elsewhere, I can't help, I still prefer Windows

          I have thought about updating the wiki pages. We need to keep the current version because we will support the current branches for a year. I see an easy way to do that, a link like that at the top of changed pages: https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=7045138 it's the actual page versionned. So I will begin to update the pages thanks to Confluence versionning almost nothing more is required

          jacques.le.roux Jacques Le Roux added a comment -

          This is basically done

          jacques.le.roux Jacques Le Roux added a comment -

          For those who would come here: I must say I stopped to use the Gradle "Eclipse Buildship" months ago. In my experience, it's not yet ready and you get more issues than help so far...


            People

            • Assignee:
              jacques.le.roux Jacques Le Roux
              Reporter:
              jacques.le.roux Jacques Le Roux
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development