Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: SVN trunk
    • Fix Version/s: SVN trunk
    • Component/s: framework
    • Labels:
      None

      Description

      with trunk rev 1232158
      runtime/logs/ofbiz.html is no more existing.
      runtime/logs has just in it the access-log

      Is this coming from the sl4j changes ?

        Activity

        Erwan de FERRIERES added a comment -

        Sascha,

        this is related to the jackrabbit merge. Could you take care of it?

        Thanks,

        Sascha Rodekamp added a comment -

        Hi Erwan,

        i made a quick test with an empty runtime/logs folder. After running the tests the folder contains the expected files (including ofbiz.html).

        Could you pls try to reproduce the failure?

        Thanks and a great day
        Sascha

        Erwan de FERRIERES added a comment -
        • svn status
          ? .idea
          ? noLog.log
          ? startlog.log
          ? migrationLang3.diff
          ? gestionFormation.diff
          M applications/accounting/widget/PaymentForms.xml
          M specialpurpose/projectmgr/widget/forms/ProjectForms.xml
        • ant clean-all run-install
        • ls runtime/logs
          README
          test-results
        • after starting OFBiz
          access_log.2012-02-02
          README
          test-results
        Sascha Rodekamp added a comment -

        Hm ok Erwan that's strange:

        • svn info:
          Revision: 1239469
          Last Changed Author: hansbak
          Last Changed Date: 02.02.12 04:02
          Last Changed Rev: 1239451
        • ant clean-all run-install
        • runtime/logs
          02.02.2012 15:52 321.444 debug.log
          02.02.2012 15:52 60.522 error.log
          02.02.2012 15:50 0 fop.log
          02.02.2012 15:50 0 minerva.log
          02.02.2012 15:52 58.874 ofbiz.html
          02.02.2012 15:52 512.116 ofbiz.html.1
          02.02.2012 15:52 505.658 ofbiz.log
          16.03.2011 09:37 46 README
        • ant run
        • runtime/logs
          02.02.2012 16:14 0 access_log.2012-02-02
          02.02.2012 16:28 1.228.572 debug.log
          02.02.2012 16:14 1.137.202 error.log
          02.02.2012 16:10 0 fop.log
          02.02.2012 16:10 0 minerva.log
          02.02.2012 16:28 200.902 ofbiz.html
          02.02.2012 16:12 512.192 ofbiz.html.1
          02.02.2012 16:28 343.065 ofbiz.log
          02.02.2012 16:12 1.024.268 ofbiz.log.1
          02.02.2012 16:12 1.024.124 ofbiz.log.2
          02.02.2012 16:12 1.024.041 ofbiz.log.3
          16.03.2011 09:37 46 README

        Maybe i try with a fresh checkout later.

        Erwan de FERRIERES added a comment -

        Just tried with a fresh checkout, same issue.

        Sascha Rodekamp added a comment -

        Ok tried also with a fresh checkout and a "ant run-install".

        After run-install the runtime/log folder contains the following files:

        03.02.2012 08:33 1.023.417 debug.log
        03.02.2012 08:02 0 error.log
        03.02.2012 08:02 0 fop.log
        03.02.2012 08:02 0 minerva.log
        03.02.2012 08:33 237.107 ofbiz.html
        03.02.2012 08:27 512.187 ofbiz.html.1
        03.02.2012 08:33 69.761 ofbiz.log
        03.02.2012 08:31 1.024.079 ofbiz.log.1
        03.02.2012 07:27 46 README
        03.02.2012 07:57 <DIR> test-results

        I'm also not sure why the slf4j should change something. Because the log4j config isn't touched.
        So something in our configuration must be different.

        Markus M. May added a comment -

        I checked this as well, and in our installation the logs occur just fine.

        Sascha Rodekamp added a comment -

        Hi Markus, thanks for the check.

        I think i will close this task for no until someone else get this problem.

        Erwan de FERRIERES added a comment -

        Hi,

        the latest log4j upgrade make it work again !

        Cheers,

        Jacques Le Roux added a comment -

        Shit happens, but good things too


          People

          • Assignee:
            Sascha Rodekamp
            Reporter:
            Erwan de FERRIERES
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development