Uploaded image for project: 'Maven WAR Plugin'
  1. Maven WAR Plugin
  2. MWAR-407

Binary files are modified during web.xml filtering; revert MWAR-404

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.1.0
    • Fix Version/s: 3.2.0
    • Component/s: filtering
    • Labels:
      None

      Description

      Binary files are being modified in case

      <filteringDeploymentDescriptors>true</filteringDeploymentDescriptors>
      

      option is used

      here is the quick-start project https://github.com/solomax/filter-war/

      UPDATE: works as expected with maven-war-plugin 3.0.0

        Issue Links

          Activity

          michael-o Michael Osipov added a comment - - edited

          This is a regression caused by MWAR-404. This diff needs to be reverted.
          The commit blindly assumes that filterDescriptors can be blindly passed to #copyFiles(). That's wrong. It will filter ALL files. The entire containerConfigXML parameter is wrong and here is the issue for MWAR-307.

          Karl Heinz Marbaise, please revert MWAR-404. The current code won't work for anything but Tomcat's container.xml. We need a general approach as described in MWAR-307.

          michael-o Michael Osipov added a comment -

          Fixed with r1809790.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #9142 (See https://builds.apache.org/job/maven-plugins/9142/)
          MWAR-407 Binary files are modified during web.xml filtering; revert MWAR-404

          This is a regression caused by MWAR-404 and therefore needs to be reverted for now. (michaelo: http://svn.apache.org/viewvc/?view=rev&rev=1809790)

          • (delete) maven-war-plugin/src/it/MWAR-404
          • (edit) maven-war-plugin/src/main/java/org/apache/maven/plugins/war/packaging/WarProjectPackagingTask.java
          mathus.b@mipih.fr Baptiste MATHUS added a comment -

          Note: this issue has been hit in last Jenkins weekly release 2.80, causing https://issues.jenkins-ci.org/browse/JENKINS-47127

          Michael Osipov Karl Heinz Marbaise can a m-war-p 3.1.1 be possibly considered with this fix? Thank you


            People

            • Assignee:
              michael-o Michael Osipov
              Reporter:
              solomax Maxim Solodovnik
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development