Uploaded image for project: 'Maven WAR Plugin'
  1. Maven WAR Plugin
  2. MWAR-404

<filteringDeploymentDescriptors>true</> is not honored

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 3.1.0
    • Component/s: filtering
    • Labels:
      None
    • Environment:

      Description

      In the zsample.webapp.zip project joined, the src/main/webapp/WEB-INF/geronimo-web.xml contains a filtered version as

      <version>${foo}</version>
      

      While the element <filteringDeploymentDescriptors>true</filteringDeploymentDescriptors> is set in the pom and the foo property is set to 4.1.1, it appears that the resulting geronimo-web.xml is not filtered.

      1. zsample.webapp.zip
        10 kB
        Francis ANDRE

        Issue Links

          Activity

          khmarbaise Karl Heinz Marbaise added a comment -

          Please use an up to date version of maven-war-plugin cause 2.2 is of 2012 ......and check if the issue still exists...

          francisandre Francis ANDRE added a comment -

          That's the same result with the 3.0.0 version
          [INFO] Scanning for projects...
          [INFO]
          [INFO] ------------------------------------------------------------------------
          [INFO] Building webapp Maven Webapp 0.0.1
          [INFO] ------------------------------------------------------------------------
          [INFO]
          [INFO] — maven-resources-plugin:2.6:resources (default-resources) @ webapp —
          [WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
          [INFO] Copying 1 resource
          [INFO]
          [INFO] — maven-compiler-plugin:3.1:compile (default-compile) @ webapp —
          [INFO] Nothing to compile - all classes are up to date
          [INFO]
          [INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ webapp —
          [WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
          [INFO] skip non existing resourceDirectory C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\src\test\resources
          [INFO]
          [INFO] — maven-compiler-plugin:3.1:testCompile (default-testCompile) @ webapp —
          [INFO] No sources to compile
          [INFO]
          [INFO] — maven-surefire-plugin:2.12.4:test (default-test) @ webapp —
          [INFO]
          [INFO] — maven-war-plugin:3.0.0:war (default-war) @ webapp —
          [INFO] Packaging webapp
          [INFO] Assembling webapp [webapp] in [C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\target\webapp]
          [INFO] Processing war project
          [INFO] Copying webapp resources [C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\src\main\webapp]
          [INFO] Webapp assembled in [130 msecs]
          [INFO] Building war: C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\target\webapp.war
          [INFO]
          [INFO] — maven-install-plugin:2.4:install (default-install) @ webapp —
          [INFO] Installing C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\target\webapp.war to C:\Users\FrancisANDRE\.m2\repository\zsample\webapp\0.0.1\webapp-0.0.1.war
          [INFO] Installing C:\MXW\DEMOS\MI-4.1.1\zsample.webapp\pom.xml to C:\Users\FrancisANDRE\.m2\repository\zsample\webapp\0.0.1\webapp-0.0.1.pom
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 5.807 s
          [INFO] Finished at: 2017-03-20T20:10:26+01:00
          [INFO] Final Memory: 12M/300M
          [INFO] ------------------------------------------------------------------------

          khmarbaise Karl Heinz Marbaise added a comment -

          Fixed in r1792380

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #8936 (See https://builds.apache.org/job/maven-plugins/8936/)
          MWAR-404 <filteringDeploymentDescriptors>true</> is not honored
          o Added IT to prove wrong behaviour and fixed the issues. (khmarbaise: http://svn.apache.org/viewvc/?view=rev&rev=1792380)

          • (add) maven-war-plugin/src/it/MWAR-404
          • (add) maven-war-plugin/src/it/MWAR-404/pom.xml
          • (add) maven-war-plugin/src/it/MWAR-404/src
          • (add) maven-war-plugin/src/it/MWAR-404/src/main
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/java
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/java/org
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/java/org/apache
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/java/org/apache/mwar404
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/java/org/apache/mwar404/Foo.java
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/WEB-INF
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/WEB-INF/geronimo-web.xml
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/WEB-INF/web.xml
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/index.jsp
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/jsp
          • (add) maven-war-plugin/src/it/MWAR-404/src/main/webapp/jsp/foo.jsp
          • (add) maven-war-plugin/src/it/MWAR-404/verify.groovy
          • (edit) maven-war-plugin/src/main/java/org/apache/maven/plugins/war/packaging/WarProjectPackagingTask.java
          michael-o Michael Osipov added a comment - - edited

          This fix introduces a severe regression and needs to be reverted.

          mathus.b@mipih.fr Baptiste MATHUS added a comment -

          Hello,
          I'm still digging into this, but this fix seems to have caused https://issues.jenkins-ci.org/browse/JENKINS-47127 FYI.

          Thanks!

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #9142 (See https://builds.apache.org/job/maven-plugins/9142/)
          MWAR-407 Binary files are modified during web.xml filtering; revert MWAR-404

          This is a regression caused by MWAR-404 and therefore needs to be reverted for now. (michaelo: http://svn.apache.org/viewvc/?view=rev&rev=1809790)

          • (delete) maven-war-plugin/src/it/MWAR-404
          • (edit) maven-war-plugin/src/main/java/org/apache/maven/plugins/war/packaging/WarProjectPackagingTask.java

            People

            • Assignee:
              khmarbaise Karl Heinz Marbaise
              Reporter:
              francisandre Francis ANDRE
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development