Uploaded image for project: 'Maven PMD Plugin'
  1. Maven PMD Plugin
  2. MPMD-220

Upgrade to PMD 5.5.1 (requires Java 7)

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.7
    • Component/s: None
    • Labels:
      None

      Description

      As 5.4.1 is out and provide some interesting improvements and bugfixes, it would be great for us to upgrade the maven plugin with this new version of PMD.

      Another important change is pmd > 5.4.0 requires Java >= 1.7.0 (see APi Changes here)

      Update: Latest version of PMD is currently 5.5.1.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                adangel Andreas Dangel
                Reporter:
                mat.boniface@gmail.com Mathieu BONIFACE
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: