Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-6508

TestNetworkedJob fails consistently due to delegation token changes on RM.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:

      Description

      Running org.apache.hadoop.mapred.TestNetworkedJob
      Tests run: 5, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 84.215 sec <<< FAILURE! - in org.apache.hadoop.mapred.TestNetworkedJob
      testNetworkedJob(org.apache.hadoop.mapred.TestNetworkedJob)  Time elapsed: 31.537 sec  <<< ERROR!
      java.io.IOException: org.apache.hadoop.yarn.exceptions.YarnException: java.io.IOException: Delegation Token can be issued only with kerberos authentication
      	at org.apache.hadoop.yarn.ipc.RPCUtil.getRemoteException(RPCUtil.java:38)
      	at org.apache.hadoop.yarn.server.resourcemanager.ClientRMService.getDelegationToken(ClientRMService.java:1044)
      	at org.apache.hadoop.yarn.api.impl.pb.service.ApplicationClientProtocolPBServiceImpl.getDelegationToken(ApplicationClientProtocolPBServiceImpl.java:325)
      	at org.apache.hadoop.yarn.proto.ApplicationClientProtocol$ApplicationClientProtocolService$2.callBlockingMethod(ApplicationClientProtocol.java:483)
      	at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:637)
      	at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:976)
      	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:2236)
      	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:2232)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.security.auth.Subject.doAs(Subject.java:415)
      	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1667)
      	at org.apache.hadoop.ipc.Server$Handler.run(Server.java:2230)
      Caused by: java.io.IOException: Delegation Token can be issued only with kerberos authentication
      	at org.apache.hadoop.yarn.server.resourcemanager.ClientRMService.getDelegationToken(ClientRMService.java:1017)
      	... 10 more
      
      	at org.apache.hadoop.ipc.Client.call(Client.java:1448)
      	at org.apache.hadoop.ipc.Client.call(Client.java:1379)
      	at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:230)
      	at com.sun.proxy.$Proxy84.getDelegationToken(Unknown Source)
      	at org.apache.hadoop.yarn.api.impl.pb.client.ApplicationClientProtocolPBClientImpl.getDelegationToken(ApplicationClientProtocolPBClientImpl.java:339)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.apache.hadoop.io.retry.RetryInvocationHandler.invokeMethod(RetryInvocationHandler.java:251)
      	at org.apache.hadoop.io.retry.RetryInvocationHandler.invoke(RetryInvocationHandler.java:103)
      	at com.sun.proxy.$Proxy85.getDelegationToken(Unknown Source)
      	at org.apache.hadoop.yarn.client.api.impl.YarnClientImpl.getRMDelegationToken(YarnClientImpl.java:541)
      	at org.apache.hadoop.mapred.ResourceMgrDelegate.getDelegationToken(ResourceMgrDelegate.java:177)
      	at org.apache.hadoop.mapred.YARNRunner.getDelegationToken(YARNRunner.java:231)
      	at org.apache.hadoop.mapreduce.Cluster.getDelegationToken(Cluster.java:401)
      	at org.apache.hadoop.mapred.JobClient$16.run(JobClient.java:1234)
      	at org.apache.hadoop.mapred.JobClient$16.run(JobClient.java:1231)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.security.auth.Subject.doAs(Subject.java:415)
      	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1667)
      	at org.apache.hadoop.mapred.JobClient.getDelegationToken(JobClient.java:1230)
      	at org.apache.hadoop.mapred.TestNetworkedJob.testNetworkedJob(TestNetworkedJob.java:260)
      
      
      1. MAPREDUCE-6508.00.patch
        2 kB
        Akira Ajisaka
      2. MAPREDUCE-6508.01.patch
        3 kB
        Akira Ajisaka

        Issue Links

          Activity

          ajisakaa Akira Ajisaka added a comment -

          Attaching a patch to remove test for delegation token (and dead code).
          First I thought setting kerberos authentication fixes the problem, however, when I set kerberos authentication, the MiniMRClientCluster didn't start. In addition, the delegation for RM is tested by TestRMDelegationTokens and TestTokenClientRMService classes. Therefore I decided to remove the test code.

          ajisakaa Akira Ajisaka added a comment -

          01:

          • Removed unused imports.
          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 6m 10s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 47s There were no new javac warning messages.
          +1 release audit 0m 21s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 35s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 28s mvn install still works.
          +1 eclipse:eclipse 0m 31s The patch built with eclipse:eclipse.
          +1 findbugs 0m 47s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          -1 mapreduce tests 104m 43s Tests failed in hadoop-mapreduce-client-jobclient.
              122m 26s  



          Reason Tests
          Failed unit tests hadoop.mapreduce.v2.TestMRJobsWithHistoryService
            hadoop.mapred.TestMiniMRClientCluster



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12768272/MAPREDUCE-6508.01.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / 124a412
          hadoop-mapreduce-client-jobclient test log https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6083/artifact/patchprocess/testrun_hadoop-mapreduce-client-jobclient.txt
          Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6083/testReport/
          Java 1.7.0_55
          uname Linux asf905.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6083/console

          This message was automatically generated.

          djp Junping Du added a comment -

          Hi Akira Ajisaka, Thanks for the patch. However, do we figure out the reason why job get failed intermittently? May be we should try to fix/understand the test problem rather than remove the test code?

          ajisakaa Akira Ajisaka added a comment -

          However, do we figure out the reason why job get failed intermittently?

          After YARN-4126, RM does not return delegation token when it's in insecure mode. That's why the following test code fails

          TestNetworkedJob#testNetworkedJob
                // test token
                Token<DelegationTokenIdentifier> token = client
                    .getDelegationToken(new Text(UserGroupInformation.getCurrentUser()
                        .getShortUserName()));
          
          djp Junping Du added a comment -

          Thanks for your reply, Akira Ajisaka! I agree it is right to remove that code in unit test which make test failed consistently. The JIRA title "intermittently" is a little misleading, and I will correct it soon.
          Latest patch (01) LGTM. +1. I will commit it shortly.

          djp Junping Du added a comment -

          I have commit latest patch to trunk and branch-2. Thanks Akira Ajisaka for delivering the patch!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8696 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8696/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #588 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/588/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          • hadoop-mapreduce-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #575 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/575/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          • hadoop-mapreduce-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1311 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1311/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          • hadoop-mapreduce-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2521 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2521/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #531 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/531/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2467 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2467/)
          MAPREDUCE-6508. TestNetworkedJob fails consistently due to delegation (junping_du: rev eb6379ca25e1bb6d3978bd3a021723c38c95bec9)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java
          suda Akihiro Suda added a comment -

          I suggest reopening this issue.

          The test fails on both of my local machine (@6702e7d66a4949a40bcdbd9f51ca1e746c8991e1, Jan 7 2016) and on Jenkins:

          Tests run: 5, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 65.041 sec <<< FAILURE! - in org.apache.hadoop.mapred.TestNetworkedJob
          testNetworkedJob(org.apache.hadoop.mapred.TestNetworkedJob)  Time elapsed: 30.412 sec  <<< FAILURE!
          org.junit.ComparisonFailure: expected:<[AM container is launched, waiting for AM container to Register with RM]> but was:<[]>
                  at org.junit.Assert.assertEquals(Assert.java:115)
                  at org.junit.Assert.assertEquals(Assert.java:144)
                  at org.apache.hadoop.mapred.TestNetworkedJob.testNetworkedJob(TestNetworkedJob.java:174)
          

          https://www.mail-archive.com/mapreduce-dev@hadoop.apache.org/msg15252.html

          https://github.com/apache/hadoop/blob/eb6379ca25e1bb6d3978bd3a021723c38c95bec9/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestNetworkedJob.java#L174

          Also, the error message is wrong: HADOOP-12693

          ajisakaa Akira Ajisaka added a comment -

          The failure of TestNetworkedJob was fixed by MAPREDUCE-6508, but after MAPREDUCE-6508, YARN-3946 broke the test again.

          org.junit.ComparisonFailure: expected:<[AM container is launched, waiting for AM container to Register with RM]> but was:<[]>
          

          This test failure is reported by MAPREDUCE-6579, and the patch in the issue will also fix the order of the arguments for assertEquals method. I'll close this issue.

          suda Akihiro Suda added a comment -

          OK, and thank you.

          Naganarasimha Naganarasimha G R added a comment -

          Hi Akira Ajisaka,
          As i understand YARN-3946 broke it once, dint get what you meant by but after MAPREDUCE-6508, YARN-3946 broke the test again. Am i missing something ?

          ajisakaa Akira Ajisaka added a comment -

          Hi Naganarasimha G R,

          but after MAPREDUCE-6508, YARN-3946 broke the test again.

          "again" is misleading. I'm sorry about that. The following is correct.

          YARN-4126 broke TestNetworkedJob and the test was fixed by MAPREDUCE-6508. After MAPREDUCE-6508, YARN-3946 broke the test. I've uploaded the patch to fix the test in MAPREDUCE-6579.

          Naganarasimha Naganarasimha G R added a comment -

          Ohh ok got the hierarchy ! thanks for the clarification


            People

            • Assignee:
              ajisakaa Akira Ajisaka
              Reporter:
              rohithsharma Rohith Sharma K S
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development