If the method returns a number, then that is what the method name should reflect. It should be called getNumBlacklistedTrackers(). The method does not return trackers, it returns number of trackers.
The same applies to the following:
- getMapTasks, getReduceTasks, getTaskTrackers
These should be deprecated and a new method should be added: getNumxxx.