Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5347

getBlacklistedTrackers() should be deprecated and a new method called getNumBlacklistedTrackers should be added.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0-beta, 2.0.5-alpha
    • Fix Version/s: None
    • Labels:
      None

      Description

      If the method returns a number, then that is what the method name should reflect. It should be called getNumBlacklistedTrackers(). The method does not return trackers, it returns number of trackers.

      The same applies to the following:

      • getMapTasks, getReduceTasks, getTaskTrackers

      These should be deprecated and a new method should be added: getNumxxx.

        Issue Links

          Activity

          Arun C Murthy added a comment -

          Sorry, we can't rename it for compatibility reasons. We could deprecate it for 3.x and remove it 4.x.

          Also, can you please consolidate jiras for javadocs? This way we don't proliferate jiras and miss important ones. Tx.

          Pranay Varma added a comment -

          I agree. I was thinking about it. I will change the summary. I was thinking about consolidation of bugs as well but created them separately to allow different assignees to work on the different bugs. But I do agree that it will result in bug proliferation. It appears that priority is of reduction of proliferation. I will consolidate. If the bugs need to be assigned to different people, I presume the primary assignee will take care.

          Pranay Varma added a comment -

          duplicate of 5342


            People

            • Assignee:
              Unassigned
              Reporter:
              Pranay Varma
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development