Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5343

reduceProgress is misleading. It should be renamed getReduceTasksProgress

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1.0-beta, 2.0.5-alpha
    • Fix Version/s: None
    • Component/s: jobtracker
    • Labels:
      None

      Description

      reduceProgress suggests that the method is going to reduce progress and is misleading because, in fact, the method provides progress information about reduce tasks. It should be renamed to match what it does: getReduceTasksProgress.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                varma.pranay Pranay Varma
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: