Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4909

TestKeyValueTextInputFormat fails with Open JDK 7 on Windows

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestKeyValueTextInputFormat.testFormat fails with Open JDK 7. The root cause appears to be a failure to delete in-use files via LocalFileSystem.delete (RawLocalFileSystem.delete).

      1. MAPREDUCE-4909.patch
        3 kB
        Arpit Agarwal
      2. MAPREDUCE-4909.patch
        3 kB
        Arpit Agarwal
      3. MAPREDUCE-4909.patch
        3 kB
        Arpit Agarwal
      4. MAPREDUCE-4909.patch
        3 kB
        Arpit Agarwal

        Issue Links

          Activity

          Arpit Agarwal added a comment -

          Submitting a patch to work around the test failures.

          Filed HADOOP-9176 to address the root cause.

          Brandon Li added a comment -

          +1, the patch looks good as a workaround.
          One minor thing, it might be good to add a "TODO" in the code comments as a reminder that the root cause is still under investigation.

          Arpit Agarwal added a comment -

          Added TODO.

          Suresh Srinivas added a comment -

          One minor thing, it might be good to add a "TODO" in the code comments as a reminder that the root cause is still under investigation.

          The goal of this test is not delete a file that is in use. So TODO seems unnecessary.

          Arpit Agarwal Also windows related comments seems inappropriate. Can a separate jira be created, related to this, to track deletion of file that is in use? I think there might already be some jiras tracking this for Windows.

          Arpit Agarwal added a comment -

          Suresh Srinivas Removed the Windows-specific comment.

          HADOOP-9176 was filed to address the root cause.

          Thanks!
          Arpit

          Arpit Agarwal added a comment -

          Removed the comments altogether.

          Suresh Srinivas added a comment -

          +1 for the patch.

          Suresh Srinivas added a comment -

          I committed the patch. Thank you Arpit!

          Suresh Srinivas added a comment -

          I also committed this change to branch-1-win.

          Arpit Agarwal added a comment -

          Thanks Suresh!

          Matt Foley added a comment -

          Closed upon release of Hadoop 1.2.0.


            People

            • Assignee:
              Arpit Agarwal
              Reporter:
              Arpit Agarwal
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development