Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-1619

Eclipse .classpath file should be generated from Ivy files to avoid duplicating dependencies

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: 0.20.3
    • Fix Version/s: 0.21.0
    • Component/s: build
    • Labels:
      None
    • Tags:
      ivy eclipse

      Description

      Using Ant-Eclipse (http://sourceforge.net/projects/ant-eclipse/) it's possible to generate Eclipse files from Ivy files, this avoids unnecessary duplication of dependencies information.

      See: HADOOP-6407

        Issue Links

          Activity

          Tom White added a comment -

          A couple of comments:

          • We should include source paths for the Java source (including tests) for each contrib module.
          • I don't think the copy task is needed in the new eclipse target.
          Paolo Castagna added a comment -

          We should include source paths for the Java source (including tests) for each contrib module.

          I followed the approach in HADOOP-6407 which does not include contrib modules.
          There are 15 contrib modules and I do not see an easy way to automate this.

          I don't think the copy task is needed in the new eclipse target.

          I left it there to copy .launch scripts, but it can be removed if you think it's better.

          I've just found out that this is a duplicate of MAPREDUCE-1592, sorry for that, I did not see it before.
          Perhaps we should close it and move discussion there.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12439724/MAPREDUCE-1619.patch
          against trunk revision 927187.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 13 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/58/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/58/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/58/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h4.grid.sp2.yahoo.net/58/console

          This message is automatically generated.


            People

            • Assignee:
              Paolo Castagna
              Reporter:
              Paolo Castagna
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development