Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.14
    • Fix Version/s: 1.2.15
    • Component/s: Appenders, Other
    • Labels:
    • Environment:
      Windows, .Net visual studio project
    • Flags:
      Patch, Important

      Description

      In AdoNetAppender.cs at line 561 :
      param.FormatValue(dbCmd, e);

      In SQLite we need to call the Prepare function before FormatValue :
      param.Prepare(dbCmd);

      If Prepare not called, then SQLite generate an ArgumentOutOfRangeException because the parameters is not defined

        Issue Links

          Activity

          Smax Maximilien Moussalli added a comment -

          perfect! Thank you

          bodewig Stefan Bodewig added a comment -

          http://archive.apache.org/dist/logging/log4net/binaries/ contains all binaries released by the Apache log4net project.

          Smax Maximilien Moussalli added a comment -

          Thanks, I will try this.
          Is it possible to download the previous version : 1.2.13?

          bodewig Stefan Bodewig added a comment -

          It should be enough to install NAnt http://nant.sourceforge.net/ (or via a package, NAnt is available on Ubuntu for example), check out trunk on a machine with Mono SDK and run "nant" in the top level directory.

          nachbarslumpi Dominik Psenner added a comment -

          That depends on many factors, but if I had to guess a date it should be within the next few weeks. Apologies, I cannot directly build log4net for mono 2.0 and this happens to be one of those factors.

          Smax Maximilien Moussalli added a comment -

          Ok sorry about this duplicate.
          Do you know, when the fix will be released?
          If not, is it possible for you to build a log4net.dll for Mono 2.0 please?
          I don't know how to proceed with the source files, to build for Mono

          nachbarslumpi Dominik Psenner added a comment -

          This is another duplicate of LOG4NET-493.


            People

            • Assignee:
              nachbarslumpi Dominik Psenner
              Reporter:
              Smax Maximilien Moussalli
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development