Uploaded image for project: 'Log4net'
  1. Log4net
  2. LOG4NET-493

Log4net 1.2.14/ADO.NET appender throws exception when starting (1.2.13 with same config works fine)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.2.14
    • Fix Version/s: 1.2.15
    • Component/s: Appenders
    • Labels:
      None
    • Environment:
      Windows 7

      Description

      Hi,

      I have upgraded to 1.2.14 but fatal exception is thrown when initializing logging. ADO.NET appender throws exception (see attached log). Config xml file (included) is same as we used with 1.2.13. With old version everything works fine.

      1. Log4NetDebugViewLog.LOG
        12 kB
        Miroslav Vanicky
      2. Log4netConfig.xml
        3 kB
        Miroslav Vanicky

        Issue Links

          Activity

          nachbarslumpi Dominik Psenner added a comment -

          Great, I'll leave this closed and marked as a duplicate.

          vande Miroslav Vanicky added a comment -

          I have compiled it from VS, tried it and it works fine.

          nachbarslumpi Dominik Psenner added a comment -

          You'll have to adjust the conditional compilation symbols too to get it to work from visual studio. If you don't want to do that you'll have to build it with nant.

          vande Miroslav Vanicky added a comment -

          Please, how to compile it from trunk to .NET 3.5? Changing project's target framework to .NET 3.5 generates some compile-errors.

          nachbarslumpi Dominik Psenner added a comment -

          You're welcome. It would be great if you could verify if the issue is indeed fixed in the latest trunk. Would you volunteer to check that?

          vande Miroslav Vanicky added a comment -

          Thank You very much for fast reaction!

          nachbarslumpi Dominik Psenner added a comment -

          This looks like a duplicate and is already fixed in trunk. A fix will be released soon, apologies for the inconvenience. If you need the fix right now please build log4net from source.


            People

            • Assignee:
              nachbarslumpi Dominik Psenner
              Reporter:
              vande Miroslav Vanicky
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development