Jetspeed 2
  1. Jetspeed 2
  2. JS2-1004

Replace dependency on JCP provided JSR-286 portlet-api-2.0 with Apache Portals maintained portlet-api_2.0_spec-1.0

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.0
    • Component/s: Dependencies
    • Labels:
      None

      Description

      Read about this task on the (long) discussion thread on general@portals.apache.org here:

      http://www.nabble.com/Should-or-must-Apache-Portals-create-and-maintain-its-own-Portlet-API-(JSR-168-286)-spec-implementation--td23054618.html

      This issue is also related to PLUTO-548 and PORTALS-14.

        Activity

        Hide
        Ate Douma added a comment - - edited

        Note: this change will required committers to checkout and install the following projects locally first as these dependencies are not yet released:

        • portals/portals-pom trunk (1.2-SNAPSHOT)
        • portals/portlet-api_2.0_spec trunk (1.0-SNAPSHOT)
        • pluto trunk (2.0.0-SNAPSHOT)
        Show
        Ate Douma added a comment - - edited Note: this change will required committers to checkout and install the following projects locally first as these dependencies are not yet released: portals/portals-pom trunk (1.2-SNAPSHOT) portals/portlet-api_2.0_spec trunk (1.0-SNAPSHOT) pluto trunk (2.0.0-SNAPSHOT)

          People

          • Assignee:
            Ate Douma
            Reporter:
            Ate Douma
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development