Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.0, 2.3.0
    • Fix Version/s: 2.3.0
    • Labels:
      None

      Description

      AddFooter does bad things with encodings.

      ------------------------------- Here is the mailing list message (replaced sensible data) ----------------------

      It seems there is a bug in AddFooter mailet..

      if i add the fooder some special chars get broken (Umlaute)

      I saved the mail to a repository before use AddFooter and after it. Here
      is the email:

      before:

      Return-Path: null
      Received: from dskfjaskdjf.de ([XX.XX.XXX.XX])
      by mail.sdks.cx (JAMES SMTP Server 2.3.0a1) with SMTP ID
      63
      for <nm@sds-de.de>;
      Wed, 22 Feb 2006 08:17:17 +0100 (CET)
      Received: (qmail 1282 invoked from network); 22 Feb 2006 07:11:21 -0000
      Received: from mail.dasjkh.de (213.157.0.167)
      by mail.sds-de.de with SMTP; 22 Feb 2006 07:11:21 -0000
      Received: (qmail 22763 invoked by uid 1011); 22 Feb 2006 07:11:27 -0000
      Received: from dskf@dasjkh.de by mail1 by uid 1003 with
      qmail-scanner-1.22
      (ExcuBAtor: 1.0.2. Clear:RC:1(213.157.14.195):SA:0(0.0/5.0):.
      Processed in 0.097302 secs); 22 Feb 2006 07:11:27 -0000
      X-Spam-Status: No, hits=0.0 required=5.0
      Received: from unknown (HELO ?192.168.210.195?) (213.157.14.195)
      by mail.dasjkh.de with SMTP; 22 Feb 2006 07:11:26 -0000
      Subject: =?ISO-8859-1?Q?Erd=F6l?=
      From: Norman Maurer <dskf@dasjkh.de>
      To: nm@sds-de.de
      Content-Type: text/plain; charset=ISO-8859-1
      Date: Wed, 22 Feb 2006 08:11:22 +0100
      Message-Id: <1140592283.8122.19.camel@localhost>
      Mime-Version: 1.0
      X-Mailer: Evolution 2.4.1
      Content-Transfer-Encoding: 8bit

      Erdöl

      after:

      Return-Path: null
      Received: from dskfjaskdjf.de ([XX.XX.XXX.XX])
      by mail.sdks.cx (JAMES SMTP Server 2.3.0a1) with SMTP ID
      63
      for <nm@sds-de.de>;
      Wed, 22 Feb 2006 08:17:17 +0100 (CET)
      Received: (qmail 1282 invoked from network); 22 Feb 2006 07:11:21 -0000
      Received: from mail.dasjkh.de (213.157.0.167)
      by mail.sds-de.de with SMTP; 22 Feb 2006 07:11:21 -0000
      Received: (qmail 22763 invoked by uid 1011); 22 Feb 2006 07:11:27 -0000
      Received: from dskf@dasjkh.de by mail1 by uid 1003 with
      qmail-scanner-1.22
      (ExcuBAtor: 1.0.2. Clear:RC:1(213.157.14.195):SA:0(0.0/5.0):.
      Processed in 0.097302 secs); 22 Feb 2006 07:11:27 -0000
      X-Spam-Status: No, hits=0.0 required=5.0
      Received: from unknown (HELO ?192.168.210.195?) (213.157.14.195)
      by mail.dasjkh.de with SMTP; 22 Feb 2006 07:11:26 -0000
      Subject: =?ISO-8859-1?Q?Erd=F6l?=
      From: Norman Maurer <dskf@dasjkh.de>
      To: nm@sds-de.de
      Content-Type: text/plain; charset=ISO-8859-15
      Date: Wed, 22 Feb 2006 08:11:22 +0100
      Message-Id: <9383078.1140592637453.JavaMail.root@Fileserver>
      Mime-Version: 1.0
      X-Mailer: Evolution 2.4.1
      Content-Transfer-Encoding: quoted-printable

      Erd=F6l

      test

      After getting in my inbox (James is a relay and send it to my other mailserver):

      Return-Path: <dskf@dasjkh.de>
      Delivered-To: nm@sds-de.de
      Received: (qmail 5491 invoked by uid 89); 22 Feb 2006 07:17:17 -0000
      Received: from localhost (HELO mail.sdks.cx) (127.0.0.1) by
      sdks.cx with SMTP; 22 Feb 2006 07:17:17 -0000
      Return-Path: null
      Received: from dskfjaskdjf.de ([XX.XX.XXX.XX]) by mail.sdks.cx
      (JAMES
      SMTP Server 2.3.0a1) with SMTP ID 63 for <nm@sds-de.de>; Wed,
      22 Feb 2006
      08:17:17 +0100 (CET)
      Received: (qmail 1282 invoked from network); 22 Feb 2006 07:11:21 -0000
      Received: from mail.dasjkh.de (213.157.0.167) by
      mail.sds-de.de
      with SMTP; 22 Feb 2006 07:11:21 -0000
      Received: (qmail 22763 invoked by uid 1011); 22 Feb 2006 07:11:27 -0000
      Received: from dskf@dasjkh.de by mail1 by uid 1003 with
      qmail-scanner-1.22 (ExcuBAtor: 1.0.2.
      Clear:RC:1(213.157.14.195):SA:0(0.0/5.0):. Processed in
      0.097302 secs); 22
      Feb 2006 07:11:27 -0000
      X-Spam-Status: No, hits=0.0 required=5.0
      Received: from unknown (HELO ?192.168.210.195?) (213.157.14.195) by
      mail.dasjkh.de with SMTP; 22 Feb 2006 07:11:26 -0000
      Subject: =?ISO-8859-1?Q?Erd=F6l?=
      From: Norman Maurer <dskf@dasjkh.de>
      To: nm@sds-de.de
      Content-Type: text/plain; charset=ISO-8859-15
      Date: Wed, 22 Feb 2006 08:11:22 +0100
      Message-Id: <9383078.1140592637453.JavaMail.root@Fileserver>
      Mime-Version: 1.0
      X-Mailer: Evolution 2.4.1
      Content-Transfer-Encoding: 8bit
      X-Evolution-Source: imap://nm%40sds-de.de@sdks.cx/

      Erd=F6l

      test

      Maybe anyone can have a look.. seems to be a bug..
      And why the : Content-Transfer-Encoding: 8bit
      is gone after adding the Fooder ?

      Should i make a Bugreport ? Can someone confirm this ?

      bye

      1. AddFooterFix-V2.patch
        2 kB
        Norman Maurer
      2. AddFooterFix.patch
        2 kB
        Norman Maurer
      3. AddFooter.patch
        2 kB
        Stefano Bagnara
      4. AddFooter.java
        9 kB
        Stefano Bagnara
      5. AddFooter.java
        11 kB
        Stefano Bagnara

        Activity

        bago Stefano Bagnara added a comment -

        Attached the patch against 2.3.0a1 and the full file patched.
        Maybe the getContentType => setHeader("Content-Type",,....) should be done in the text part, too.

        This should be tested and confirmed before commit.

        bago Stefano Bagnara added a comment -

        Updated AddFooter.java
        This should work with every "system" encoding configuration.

        norman Norman Maurer added a comment -

        After a few test there seems no problems here anymore..
        But have to test it a bit more

        bago Stefano Bagnara added a comment -

        Should be fixed: I ran the new test with different file.encoding and default mime charsets and it seems to work.
        Footer text should be 7bit (no special chars) or it will be added fine only when the charset of the incoming message is compatible with the charset of the footer.

        norman Norman Maurer added a comment -

        There seems to be a bug in this again. The Fooder is not add but the messageget corrupted.

        Here is a message send through james without AddFooter:

        Return-Path: <clamav-virusdb-bounces@lists.clamav.net>
        Delivered-To: nm@spam-box.de
        Received: (qmail 12927 invoked by uid 89); 6 Mar 2006 12:58:04 -0000
        Received: from localhost (HELO mail.guden.ath.cx) (127.0.0.1) by
        guden.ath.cx with SMTP; 6 Mar 2006 12:58:04 -0000
        Return-Path: null
        Received: from hiphopcorner.de ([62.75.159.71]) by mail.guden.ath.cx (JAMES
        SMTP Server 2.3-dev) with SMTP ID 830 for <nm@spam-box.de>; Mon, 6 Mar 2006
        13:58:02 +0100 (CET)
        Received: (qmail 12805 invoked by uid 0); 6 Mar 2006 12:57:14 -0000
        Delivered-To: nm@spam-box.de
        Received: (qmail 7572 invoked by uid 89); 31 Jan 2006 14:59:15 -0000
        Received: from localhost (HELO mail.guden.ath.cx) (127.0.0.1) by
        guden.ath.cx with SMTP; 31 Jan 2006 14:59:15 -0000
        Received: from vserver ([62.75.159.71]) by mail.guden.ath.cx (JAMES SMTP
        Server 2.3-dev) with SMTP ID 531 for <nm@spam-box.de>; Tue, 31 Jan 2006
        15:59:13 +0100 (CET)
        Received: (qmail 803 invoked by uid 1002); 31 Jan 2006 14:54:06 -0000
        Received: from aj.catt.com (HELO aj.catt.com) (64.18.103.6) by
        mail.spam-box.de (qpsmtpd/0.31.1) with ESMTP; Tue, 31 Jan 2006 15:54:06
        +0100
        Received: from aj.catt.com (localhost [127.0.0.1]) by aj.catt.com (Postfix)
        with ESMTP id 1702515611D; Tue, 31 Jan 2006 09:51:54 -0500 (EST)
        Received: from mail.softcom.dk (mail.softcom.dk [217.157.23.229]) by
        aj.catt.com (Postfix) with ESMTP id CFB4B156115 for
        <clamav-virusdb@lists.clamav.net>; Tue, 31 Jan 2006 09:51:42 -0500 (EST)
        Received: from [172.29.10.77] ([217.157.23.228]) by mail.softcom.dk over
        TLS secured channel with Microsoft SMTPSVC(6.0.3790.1830); Tue, 31 Jan
        2006 15:51:39 +0100
        Message-ID: <8687308.1141649884161.JavaMail.root@Fileserver>
        Date: Tue, 31 Jan 2006 15:51:20 +0100
        From: Diego d'Ambra <da@softcom.dk>
        Organization: SoftCom Solutions
        User-Agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)
        X-Accept-Language: en-us, en
        MIME-Version: 1.0
        To: ClamAV virus update <clamav-virusdb@lists.clamav.net>
        X-OriginalArrivalTime: 31 Jan 2006 14:51:39.0678 (UTC)
        FILETIME=[D798C3E0:01C62675]
        Subject: [Clamav-virusdb] Update (daily: 1263)
        X-BeenThere: clamav-virusdb@lists.clamav.net
        X-Mailman-Version: 2.1.5
        Precedence: list
        Reply-To: noreply@clamav.net
        List-Id: ClamAV VirusDB announcements <clamav-virusdb.lists.clamav.net>
        List-Unsubscribe:
        <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>,
        <clamav-virusdb-request@lists.clamav.net?subject=unsubscribe>
        List-Post: <clamav-virusdb@lists.clamav.net>
        List-Help: <clamav-virusdb-request@lists.clamav.net?subject=help>
        List-Subscribe:
        <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>,
        <clamav-virusdb-request@lists.clamav.net?subject=subscribe>
        Content-Type: multipart/mixed; boundary="===============0204599088=="
        Sender: clamav-virusdb-bounces@lists.clamav.net
        Errors-To: clamav-virusdb-bounces@lists.clamav.net
        X-EXCUBATOR-Processed: Tue Jan 31 15 59 14 2006
        X-EXCUBATOR-Signature: 2,43df7b4275599035381283
        X-EXCUBATOR-Improbability: 1 in 162 chance of being spam
        X-EXCUBATOR-Result: Innocent
        X-EXCUBATOR-Probability: 0.0000
        X-EXCUBATOR-Confidence: 0.6171
        X-EXCUBATOR-User: nm@spam-box.de
        X-EXCUBATOR-Domain: spam-box.de
        X-EXCUBATOR-Infected: false
        X-Evolution-Source: imap://nm%40spam-box.de@guden.ath.cx/

        This is a cryptographically signed message in MIME format.

        --===============0204599088==
        Content-Type: multipart/signed; protocol="application/x-pkcs7-signature"; micalg=sha1; boundary="------------ms050404020900070803030808"

        This is a cryptographically signed message in MIME format.

        --------------ms050404020900070803030808
        Content-Type: text/plain; charset=ISO-8859-1; format=flowed
        Content-Transfer-Encoding: 7bit

        ClamAV database updated (2006-Jan-31 14:48 +0000): daily.cvd
        version: 1263

        Submission: 214667
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214669
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214675
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214685
        Sender: Bret Miller
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214709
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214741
        Sender: Nicola Fitzgerald
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214768
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214770
        Sender: Stephen V Trovato
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214788
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214791
        Sender: Jotti
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214792
        Sender: Emmanuel Nicaise
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214797
        Sender: Dave Funk
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214811
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214870
        Sender: ECSC Team
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214896
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214904
        Sender: Jason Tibbitts
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214911
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214961
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214971
        Sender: Richard Stubbs
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215021
        Sender: Pete Lombardo
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215022
        Sender: Jotti
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215032
        Sender: Steve Swanson
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215066
        Sender: Anonymous
        Submission notes: Email with broken zip archive (0 bytes). Harmless.
        Added: No

        Submission: 215578
        Sender: Dimitrios Vardalis
        Added: Trojan.Brepibot.R
        Virus name alias: BehavesLike:Win32.IRC-Backdoor (Bitdefender)

        Best regards,
        Diego d'Ambra

        --------------ms050404020900070803030808
        Content-Type: application/x-pkcs7-signature; name="smime.p7s"
        Content-Transfer-Encoding: base64
        Content-Disposition: attachment; filename="smime.p7s"
        Content-Description: S/MIME Cryptographic Signature

        MIAGCSqGSIb3DQEHAqCAMIACAQExCzAJBgUrDgMCGgUAMIAGCSqGSIb3DQEHAQAAoIIH/zCC
        AlowggHDoAMCAQICAw4l+zANBgkqhkiG9w0BAQQFADBiMQswCQYDVQQGEwJaQTElMCMGA1UE
        ChMcVGhhd3RlIENvbnN1bHRpbmcgKFB0eSkgTHRkLjEsMCoGA1UEAxMjVGhhd3RlIFBlcnNv
        bmFsIEZyZWVtYWlsIElzc3VpbmcgQ0EwHhcNMDUwMjI4MTQzMjQxWhcNMDYwMjI4MTQzMjQx
        WjBWMQ8wDQYDVQQEEwZEYW1icmExDjAMBgNVBCoTBURpZWdvMRUwEwYDVQQDEwxEaWVnbyBE
        YW1icmExHDAaBgkqhkiG9w0BCQEWDWRhQHNvZnRjb20uZGswgZ8wDQYJKoZIhvcNAQEBBQAD
        gY0AMIGJAoGBAJrofdTKVSLoqqN6Rv70LSjlKj1KA/3swZI0haFbo56TlIJJyhbdpO4p4x8v
        09aCDY2SZrgh325M8jR5gjVeSKGYSVWjl5TZVSZWIrObpaa15f95ubz/muoZRhCIOEiXSdRX
        ijDYxNqCfOpggkjCobx9mR6LWoRmMnHOoC6TbvchAgMBAAGjKjAoMBgGA1UdEQQRMA+BDWRh
        QHNvZnRjb20uZGswDAYDVR0TAQH/BAIwADANBgkqhkiG9w0BAQQFAAOBgQAVxBYcnGhXYQEm
        FTUk4K5PolMjDQEYAxj8U7YGUawzhQIuYg0YNUl1Lv1bx+OW1MD+qI1bipleIQ+RbzfZ39PE
        6rgJPagvbj4luwY/A/pRXed5rP7GDvwQudJsjiCkf4fkXYbnHgFWjdIaZJN4sgCDPagV0Gfx
        OXxd3juP4jJmozCCAlowggHDoAMCAQICAw4l+zANBgkqhkiG9w0BAQQFADBiMQswCQYDVQQG
        EwJaQTElMCMGA1UEChMcVGhhd3RlIENvbnN1bHRpbmcgKFB0eSkgTHRkLjEsMCoGA1UEAxMj
        VGhhd3RlIFBlcnNvbmFsIEZyZWVtYWlsIElzc3VpbmcgQ0EwHhcNMDUwMjI4MTQzMjQxWhcN
        MDYwMjI4MTQzMjQxWjBWMQ8wDQYDVQQEEwZEYW1icmExDjAMBgNVBCoTBURpZWdvMRUwEwYD
        VQQDEwxEaWVnbyBEYW1icmExHDAaBgkqhkiG9w0BCQEWDWRhQHNvZnRjb20uZGswgZ8wDQYJ
        KoZIhvcNAQEBBQADgY0AMIGJAoGBAJrofdTKVSLoqqN6Rv70LSjlKj1KA/3swZI0haFbo56T
        lIJJyhbdpO4p4x8v09aCDY2SZrgh325M8jR5gjVeSKGYSVWjl5TZVSZWIrObpaa15f95ubz/
        muoZRhCIOEiXSdRXijDYxNqCfOpggkjCobx9mR6LWoRmMnHOoC6TbvchAgMBAAGjKjAoMBgG
        A1UdEQQRMA+BDWRhQHNvZnRjb20uZGswDAYDVR0TAQH/BAIwADANBgkqhkiG9w0BAQQFAAOB
        gQAVxBYcnGhXYQEmFTUk4K5PolMjDQEYAxj8U7YGUawzhQIuYg0YNUl1Lv1bx+OW1MD+qI1b
        ipleIQ+RbzfZ39PE6rgJPagvbj4luwY/A/pRXed5rP7GDvwQudJsjiCkf4fkXYbnHgFWjdIa
        ZJN4sgCDPagV0GfxOXxd3juP4jJmozCCAz8wggKooAMCAQICAQ0wDQYJKoZIhvcNAQEFBQAw
        gdExCzAJBgNVBAYTAlpBMRUwEwYDVQQIEwxXZXN0ZXJuIENhcGUxEjAQBgNVBAcTCUNhcGUg
        VG93bjEaMBgGA1UEChMRVGhhd3RlIENvbnN1bHRpbmcxKDAmBgNVBAsTH0NlcnRpZmljYXRp
        b24gU2VydmljZXMgRGl2aXNpb24xJDAiBgNVBAMTG1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFp
        bCBDQTErMCkGCSqGSIb3DQEJARYccGVyc29uYWwtZnJlZW1haWxAdGhhd3RlLmNvbTAeFw0w
        MzA3MTcwMDAwMDBaFw0xMzA3MTYyMzU5NTlaMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxU
        aGF3dGUgQ29uc3VsdGluZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwg
        RnJlZW1haWwgSXNzdWluZyBDQTCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEAxKY8VXNV
        +065yplaHmjAdQRwnd/p/6Me7L3N9VvyGna9fww6YfK/Uc4B1OVQCjDXAmNaLIkVcI7dyfAr
        hVqqP3FWy688Cwfn8R+RNiQqE88r1fOCdz0Dviv+uxg+B79AgAJk16emu59l0cUqVIUPSAR/
        p7bRPGEEQB5kGXJgt/sCAwEAAaOBlDCBkTASBgNVHRMBAf8ECDAGAQH/AgEAMEMGA1UdHwQ8
        MDowOKA2oDSGMmh0dHA6Ly9jcmwudGhhd3RlLmNvbS9UaGF3dGVQZXJzb25hbEZyZWVtYWls
        Q0EuY3JsMAsGA1UdDwQEAwIBBjApBgNVHREEIjAgpB4wHDEaMBgGA1UEAxMRUHJpdmF0ZUxh
        YmVsMi0xMzgwDQYJKoZIhvcNAQEFBQADgYEASIzRUIPqCy7MDaNmrGcPf6+svsIXoUOWlJ1/
        TCG4+DYfqi2fNi/A9BxQIJNwPP2t4WFiw9k6GX6EsZkbAMUaC4J0niVQlGLH2ydxVyWN3amc
        OY6MIE9lX5Xa9/eH1sYITq726jTlEBpbNU1341YheILcIRk13iSx0x1G/11fZU8xggK6MIIC
        tgIBATBpMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGluZyAoUHR5
        KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNzdWluZyBDQQID
        DiX7MAkGBSsOAwIaBQCgggGnMBgGCSqGSIb3DQEJAzELBgkqhkiG9w0BBwEwHAYJKoZIhvcN
        AQkFMQ8XDTA2MDEzMTE0NTEyMFowIwYJKoZIhvcNAQkEMRYEFK00VMZVIW22gypx9bTvEqNV
        1w0LMFIGCSqGSIb3DQEJDzFFMEMwCgYIKoZIhvcNAwcwDgYIKoZIhvcNAwICAgCAMA0GCCqG
        SIb3DQMCAgFAMAcGBSsOAwIHMA0GCCqGSIb3DQMCAgEoMHgGCSsGAQQBgjcQBDFrMGkwYjEL
        MAkGA1UEBhMCWkExJTAjBgNVBAoTHFRoYXd0ZSBDb25zdWx0aW5nIChQdHkpIEx0ZC4xLDAq
        BgNVBAMTI1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFpbCBJc3N1aW5nIENBAgMOJfswegYLKoZI
        hvcNAQkQAgsxa6BpMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGlu
        ZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNzdWlu
        ZyBDQQIDDiX7MA0GCSqGSIb3DQEBAQUABIGAjHgojHZRlVyqMGfNRpOrzjU1brh3j7yqpMch
        FcFvgn4f+0GUA731dMMaWnUhp+qmgG9U0bQqhonNiLP1lQ+liMnkJ23NS/pIpXQjoDR+mfbB
        kXoQRbnZdrHYslrxCPnq/70my6xrhlS/7DUJUejrm10iuMtEUsuMiG3fcADlF1kAAAAAAAA=
        -------------ms050404020900070803030808-

        --===============0204599088==
        Content-Type: text/plain; charset="us-ascii"
        MIME-Version: 1.0
        Content-Transfer-Encoding: 7bit
        Content-Disposition: inline

        _______________________________________________
        http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb

        -===============0204599088==-

        And here with AddFooter:

        Return-Path: <clamav-virusdb-bounces@lists.clamav.net>
        Delivered-To: nm@spam-box.de
        Received: (qmail 13086 invoked by uid 89); 6 Mar 2006 12:59:46 -0000
        Received: from localhost (HELO mail.guden.ath.cx) (127.0.0.1) by guden.ath.cx with SMTP; 6 Mar 2006 12:59:46 -0000
        Return-Path: null
        Received: from hiphopcorner.de ([62.75.159.71]) by mail.guden.ath.cx (JAMES SMTP Server 2.3-dev) with SMTP ID 659 for <nm@spam-box.de>; Mon, 6 Mar 2006 13:59:45 +0100 (CET)
        Received: (qmail 31489 invoked by uid 0); 6 Mar 2006 12:58:54 -0000
        Delivered-To: nm@spam-box.de
        Received: (qmail 7572 invoked by uid 89); 31 Jan 2006 14:59:15 -0000
        Received: from localhost (HELO mail.guden.ath.cx) (127.0.0.1) by guden.ath.cx with SMTP; 31 Jan 2006 14:59:15 -0000
        Received: from vserver ([62.75.159.71]) by mail.guden.ath.cx (JAMES SMTP Server 2.3-dev) with SMTP ID 531 for <nm@spam-box.de>; Tue, 31 Jan 2006 15:59:13 +0100 (CET)
        Received: (qmail 803 invoked by uid 1002); 31 Jan 2006 14:54:06 -0000
        Received: from aj.catt.com (HELO aj.catt.com) (64.18.103.6) by mail.spam-box.de (qpsmtpd/0.31.1) with ESMTP; Tue, 31 Jan 2006 15:54:06 +0100
        Received: from aj.catt.com (localhost [127.0.0.1]) by aj.catt.com (Postfix) with ESMTP id 1702515611D; Tue, 31 Jan 2006 09:51:54 -0500 (EST)
        Received: from mail.softcom.dk (mail.softcom.dk [217.157.23.229]) by aj.catt.com (Postfix) with ESMTP id CFB4B156115 for <clamav-virusdb@lists.clamav.net>; Tue, 31 Jan 2006 09:51:42 -0500 (EST)
        Received: from [172.29.10.77] ([217.157.23.228]) by mail.softcom.dk over TLS secured channel with Microsoft SMTPSVC(6.0.3790.1830); Tue, 31 Jan 2006 15:51:39 +0100
        Message-ID: <16009656.1141649986223.JavaMail.root@Fileserver>
        Datum: Tue, 31 Jan 2006 15:51:20 +0100
        Von: Diego d'Ambra <da@softcom.dk>
        Organization: SoftCom Solutions
        User-Agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)
        X-Accept-Language: en-us, en
        MIME-Version: 1.0
        An: ClamAV virus update <clamav-virusdb@lists.clamav.net>
        X-OriginalArrivalTime: 31 Jan 2006 14:51:39.0678 (UTC) FILETIME=[D798C3E0:01C62675]
        Betreff: [Clamav-virusdb] Update (daily: 1263)
        X-BeenThere: clamav-virusdb@lists.clamav.net
        X-Mailman-Version: 2.1.5
        Precedence: list
        Antwort an: noreply@clamav.net
        List-Id: ClamAV VirusDB announcements <clamav-virusdb.lists.clamav.net>
        List-Unsubscribe: <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>, <clamav-virusdb-request@lists.clamav.net?subject=unsubscribe>
        List-Post: <clamav-virusdb@lists.clamav.net>
        List-Help: <clamav-virusdb-request@lists.clamav.net?subject=help>
        List-Subscribe: <http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb>, <clamav-virusdb-request@lists.clamav.net?subject=subscribe>
        Absender: clamav-virusdb-bounces@lists.clamav.net
        Errors-To: clamav-virusdb-bounces@lists.clamav.net
        X-EXCUBATOR-Processed: Tue Jan 31 15 59 14 2006
        X-EXCUBATOR-Signature: 2,43df7b4275599035381283
        X-EXCUBATOR-Improbability: 1 in 162 chance of being spam
        X-EXCUBATOR-Result: Innocent
        X-EXCUBATOR-Probability: 0.0000
        X-EXCUBATOR-Confidence: 0.6171
        X-EXCUBATOR-User: nm@spam-box.de
        X-EXCUBATOR-Domain: spam-box.de
        X-EXCUBATOR-Infected: false
        Content-Transfer-Encoding: 7bit
        X-Evolution-Source: imap://nm%40spam-box.de@guden.ath.cx/

        --===============0204599088==
        Content-Type: multipart/signed; protocol="application/x-pkcs7-signature";
        micalg=sha1; boundary="------------ms050404020900070803030808"

        This is a cryptographically signed message in MIME format.

        --------------ms050404020900070803030808
        Content-Type: text/plain; charset=ISO-8859-1; format=flowed
        Content-Transfer-Encoding: 7bit

        ClamAV database updated (2006-Jan-31 14:48 +0000): daily.cvd
        version: 1263

        Submission: 214667
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214669
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214675
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214685
        Sender: Bret Miller
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214709
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214741
        Sender: Nicola Fitzgerald
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214768
        Sender: Virus Total
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214770
        Sender: Stephen V Trovato
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214788
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214791
        Sender: Jotti
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214792
        Sender: Emmanuel Nicaise
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214797
        Sender: Dave Funk
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214811
        Sender: Anonymous
        Submission notes: Same as in submission 214743
        Added: No

        Submission: 214870
        Sender: ECSC Team
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214896
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214904
        Sender: Jason Tibbitts
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214911
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214961
        Sender: Virus Total
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 214971
        Sender: Richard Stubbs
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215021
        Sender: Pete Lombardo
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215022
        Sender: Jotti
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215032
        Sender: Steve Swanson
        Submission notes: Same as in submission 214867
        Added: No

        Submission: 215066
        Sender: Anonymous
        Submission notes: Email with broken zip archive (0 bytes). Harmless.
        Added: No

        Submission: 215578
        Sender: Dimitrios Vardalis
        Added: Trojan.Brepibot.R
        Virus name alias: BehavesLike:Win32.IRC-Backdoor (Bitdefender)

        Best regards,
        Diego d'Ambra

        --------------ms050404020900070803030808
        Content-Type: application/x-pkcs7-signature; name="smime.p7s"
        Content-Transfer-Encoding: base64
        Content-Disposition: attachment; filename="smime.p7s"
        Content-Description: S/MIME Cryptographic Signature

        MIAGCSqGSIb3DQEHAqCAMIACAQExCzAJBgUrDgMCGgUAMIAGCSqGSIb3DQEHAQAAoIIH/zCC
        AlowggHDoAMCAQICAw4l+zANBgkqhkiG9w0BAQQFADBiMQswCQYDVQQGEwJaQTElMCMGA1UE
        ChMcVGhhd3RlIENvbnN1bHRpbmcgKFB0eSkgTHRkLjEsMCoGA1UEAxMjVGhhd3RlIFBlcnNv
        bmFsIEZyZWVtYWlsIElzc3VpbmcgQ0EwHhcNMDUwMjI4MTQzMjQxWhcNMDYwMjI4MTQzMjQx
        WjBWMQ8wDQYDVQQEEwZEYW1icmExDjAMBgNVBCoTBURpZWdvMRUwEwYDVQQDEwxEaWVnbyBE
        YW1icmExHDAaBgkqhkiG9w0BCQEWDWRhQHNvZnRjb20uZGswgZ8wDQYJKoZIhvcNAQEBBQAD
        gY0AMIGJAoGBAJrofdTKVSLoqqN6Rv70LSjlKj1KA/3swZI0haFbo56TlIJJyhbdpO4p4x8v
        09aCDY2SZrgh325M8jR5gjVeSKGYSVWjl5TZVSZWIrObpaa15f95ubz/muoZRhCIOEiXSdRX
        ijDYxNqCfOpggkjCobx9mR6LWoRmMnHOoC6TbvchAgMBAAGjKjAoMBgGA1UdEQQRMA+BDWRh
        QHNvZnRjb20uZGswDAYDVR0TAQH/BAIwADANBgkqhkiG9w0BAQQFAAOBgQAVxBYcnGhXYQEm
        FTUk4K5PolMjDQEYAxj8U7YGUawzhQIuYg0YNUl1Lv1bx+OW1MD+qI1bipleIQ+RbzfZ39PE
        6rgJPagvbj4luwY/A/pRXed5rP7GDvwQudJsjiCkf4fkXYbnHgFWjdIaZJN4sgCDPagV0Gfx
        OXxd3juP4jJmozCCAlowggHDoAMCAQICAw4l+zANBgkqhkiG9w0BAQQFADBiMQswCQYDVQQG
        EwJaQTElMCMGA1UEChMcVGhhd3RlIENvbnN1bHRpbmcgKFB0eSkgTHRkLjEsMCoGA1UEAxMj
        VGhhd3RlIFBlcnNvbmFsIEZyZWVtYWlsIElzc3VpbmcgQ0EwHhcNMDUwMjI4MTQzMjQxWhcN
        MDYwMjI4MTQzMjQxWjBWMQ8wDQYDVQQEEwZEYW1icmExDjAMBgNVBCoTBURpZWdvMRUwEwYD
        VQQDEwxEaWVnbyBEYW1icmExHDAaBgkqhkiG9w0BCQEWDWRhQHNvZnRjb20uZGswgZ8wDQYJ
        KoZIhvcNAQEBBQADgY0AMIGJAoGBAJrofdTKVSLoqqN6Rv70LSjlKj1KA/3swZI0haFbo56T
        lIJJyhbdpO4p4x8v09aCDY2SZrgh325M8jR5gjVeSKGYSVWjl5TZVSZWIrObpaa15f95ubz/
        muoZRhCIOEiXSdRXijDYxNqCfOpggkjCobx9mR6LWoRmMnHOoC6TbvchAgMBAAGjKjAoMBgG
        A1UdEQQRMA+BDWRhQHNvZnRjb20uZGswDAYDVR0TAQH/BAIwADANBgkqhkiG9w0BAQQFAAOB
        gQAVxBYcnGhXYQEmFTUk4K5PolMjDQEYAxj8U7YGUawzhQIuYg0YNUl1Lv1bx+OW1MD+qI1b
        ipleIQ+RbzfZ39PE6rgJPagvbj4luwY/A/pRXed5rP7GDvwQudJsjiCkf4fkXYbnHgFWjdIa
        ZJN4sgCDPagV0GfxOXxd3juP4jJmozCCAz8wggKooAMCAQICAQ0wDQYJKoZIhvcNAQEFBQAw
        gdExCzAJBgNVBAYTAlpBMRUwEwYDVQQIEwxXZXN0ZXJuIENhcGUxEjAQBgNVBAcTCUNhcGUg
        VG93bjEaMBgGA1UEChMRVGhhd3RlIENvbnN1bHRpbmcxKDAmBgNVBAsTH0NlcnRpZmljYXRp
        b24gU2VydmljZXMgRGl2aXNpb24xJDAiBgNVBAMTG1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFp
        bCBDQTErMCkGCSqGSIb3DQEJARYccGVyc29uYWwtZnJlZW1haWxAdGhhd3RlLmNvbTAeFw0w
        MzA3MTcwMDAwMDBaFw0xMzA3MTYyMzU5NTlaMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxU
        aGF3dGUgQ29uc3VsdGluZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwg
        RnJlZW1haWwgSXNzdWluZyBDQTCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEAxKY8VXNV
        +065yplaHmjAdQRwnd/p/6Me7L3N9VvyGna9fww6YfK/Uc4B1OVQCjDXAmNaLIkVcI7dyfAr
        hVqqP3FWy688Cwfn8R+RNiQqE88r1fOCdz0Dviv+uxg+B79AgAJk16emu59l0cUqVIUPSAR/
        p7bRPGEEQB5kGXJgt/sCAwEAAaOBlDCBkTASBgNVHRMBAf8ECDAGAQH/AgEAMEMGA1UdHwQ8
        MDowOKA2oDSGMmh0dHA6Ly9jcmwudGhhd3RlLmNvbS9UaGF3dGVQZXJzb25hbEZyZWVtYWls
        Q0EuY3JsMAsGA1UdDwQEAwIBBjApBgNVHREEIjAgpB4wHDEaMBgGA1UEAxMRUHJpdmF0ZUxh
        YmVsMi0xMzgwDQYJKoZIhvcNAQEFBQADgYEASIzRUIPqCy7MDaNmrGcPf6+svsIXoUOWlJ1/
        TCG4+DYfqi2fNi/A9BxQIJNwPP2t4WFiw9k6GX6EsZkbAMUaC4J0niVQlGLH2ydxVyWN3amc
        OY6MIE9lX5Xa9/eH1sYITq726jTlEBpbNU1341YheILcIRk13iSx0x1G/11fZU8xggK6MIIC
        tgIBATBpMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGluZyAoUHR5
        KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNzdWluZyBDQQID
        DiX7MAkGBSsOAwIaBQCgggGnMBgGCSqGSIb3DQEJAzELBgkqhkiG9w0BBwEwHAYJKoZIhvcN
        AQkFMQ8XDTA2MDEzMTE0NTEyMFowIwYJKoZIhvcNAQkEMRYEFK00VMZVIW22gypx9bTvEqNV
        1w0LMFIGCSqGSIb3DQEJDzFFMEMwCgYIKoZIhvcNAwcwDgYIKoZIhvcNAwICAgCAMA0GCCqG
        SIb3DQMCAgFAMAcGBSsOAwIHMA0GCCqGSIb3DQMCAgEoMHgGCSsGAQQBgjcQBDFrMGkwYjEL
        MAkGA1UEBhMCWkExJTAjBgNVBAoTHFRoYXd0ZSBDb25zdWx0aW5nIChQdHkpIEx0ZC4xLDAq
        BgNVBAMTI1RoYXd0ZSBQZXJzb25hbCBGcmVlbWFpbCBJc3N1aW5nIENBAgMOJfswegYLKoZI
        hvcNAQkQAgsxa6BpMGIxCzAJBgNVBAYTAlpBMSUwIwYDVQQKExxUaGF3dGUgQ29uc3VsdGlu
        ZyAoUHR5KSBMdGQuMSwwKgYDVQQDEyNUaGF3dGUgUGVyc29uYWwgRnJlZW1haWwgSXNzdWlu
        ZyBDQQIDDiX7MA0GCSqGSIb3DQEBAQUABIGAjHgojHZRlVyqMGfNRpOrzjU1brh3j7yqpMch
        FcFvgn4f+0GUA731dMMaWnUhp+qmgG9U0bQqhonNiLP1lQ+liMnkJ23NS/pIpXQjoDR+mfbB
        kXoQRbnZdrHYslrxCPnq/70my6xrhlS/7DUJUejrm10iuMtEUsuMiG3fcADlF1kAAAAAAAA=
        -------------ms050404020900070803030808-

        --===============0204599088==
        Content-Type: text/plain; charset="us-ascii"
        MIME-Version: 1.0
        Content-Transfer-Encoding: 7bit
        Content-Disposition: inline

        _______________________________________________
        http://lists.clamav.net/cgi-bin/mailman/listinfo/clamav-virusdb

        -===============0204599088==-

        norman Norman Maurer added a comment -

        Forget to say that i use the latest Trunk with java 1.5

        norman Norman Maurer added a comment -

        The Problem seems that the part.setContent(multipart); is used if the Footer can not add..

        Here is a patch that seems to fix it. Patch is made against latest trunk

        norman Norman Maurer added a comment -

        Fix for AddFooter.

        norman Norman Maurer added a comment -

        Just notice that the problem can also happen on a other place. I fixed it to. Just ignore the first uploaded patch and only apply this.

        bago Stefano Bagnara added a comment -

        Applied the patch from Norman and a new test for the scenario.

        danny@apache.org Danny Angus added a comment -

        Closing issue fixed in released version.


          People

          • Assignee:
            bago Stefano Bagnara
            Reporter:
            bago Stefano Bagnara
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development