IvyDE
  1. IvyDE
  2. IVYDE-161

REGRESSION: Resolving does no longer respect configurations

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.final
    • Fix Version/s: 2.0.0.final
    • Component/s: classpath container
    • Labels:
      None

      Description

      This happens in the current trunk. I think the bug was introduced with the fix for IVYDE-140.
      IvyDe now seems to merge the configurations from resolve and "retrieve after resolve" event if "retrieve after resolve" is not enabled.
      I've marked this blocker since a central and once working feature does no longer work.

      How to Reproduce:
      Add a IvyDe Classpath Container for an ivy.xml with multiple configurations but set Ivy to Resolve only one of them.
      Leave the "Retrieve after resolve" Option unchecked.
      IvyDe will resolve all configurations.

      Workaround:
      Activate Retrieve after resolve and enter the correct configuration a second time. You willl endup with resolved artifacst but IvyDe will now only resolve the wanted confiugration.

        Activity

        Nicolas Lalevée added a comment -

        fixed in trunk, along with some fix about hazardous merging of configuration set.
        Could you give a try with the last build ?

        Martin Eigenbrodt added a comment -

        I'm sorry but Due to appointments and vacations I can not give this a try
        until Mai 30.
        Martin

        2009/2/9 Nicolas Lalevée (JIRA) <jira@apache.org>

        Martin Eigenbrodt added a comment -

        I've tested today with the latest IvyDe from Hudson. Works finde for me.


          People

          • Assignee:
            Nicolas Lalevée
            Reporter:
            Martin Eigenbrodt
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development