IvyDE
  1. IvyDE
  2. IVYDE-140

Retrieve after resolve task fails because of wrong resolve configuration.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0.beta1
    • Fix Version/s: 2.0.0.final
    • Component/s: classpath container
    • Labels:
      None

      Description

      Retrive after resolve task fails because of wrong resolve configuration.

      If you have set on your ivy.xml a different configuration than the configuration in the retrieve after resolve textfield,
      the retrieve step will fail because no resolve was run for selected configuration.

      How to reproduce:
      Right click on your ivy.xml classpath and change the configuration to master. Then go to Window-> Preferences->Ivy check "Do retrieve after resolve"
      and enter "runtime" in configuration text box. Close your eclipse. Remove your .ivy2 cache file. Startup your eclipse and you will get the error.

      Fix

      Merge the configuration needed for classpath setting and configurations needed by retrieve before doing resolve.

      1. IVYDE-140.txt
        3 kB
        Daniel Becheanu

        Issue Links

          Activity

          Daniel Becheanu created issue -
          Daniel Becheanu made changes -
          Field Original Value New Value
          Attachment IVYDE-140.txt [ 12396250 ]
          Daniel Becheanu made changes -
          Affects Version/s 2.0.0.beta1 [ 12313273 ]
          Daniel Becheanu made changes -
          Component/s classpath container [ 12311720 ]
          Nicolas Lalevée made changes -
          Summary Retrive after resolve task fails because of wrong resolve configuration. Retrieve after resolve task fails because of wrong resolve configuration.
          Nicolas Lalevée added a comment -

          I reproduced it with a 'test' project and fixed it with your patch. Thanks!

          Nicolas Lalevée made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 2.0.0.final [ 12313533 ]
          Assignee Nicolas Lalevée [ hibou ]
          Resolution Fixed [ 1 ]
          Nicolas Lalevée made changes -
          Link This issue is duplicated by IVYDE-148 [ IVYDE-148 ]
          Nicolas Lalevée made changes -
          Link This issue is duplicated by IVYDE-154 [ IVYDE-154 ]
          Nicolas Lalevée made changes -
          Link This issue is duplicated by IVYDE-160 [ IVYDE-160 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          13d 17h 44m 1 Nicolas Lalevée 30/Dec/08 16:14

            People

            • Assignee:
              Nicolas Lalevée
              Reporter:
              Daniel Becheanu
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development