Ivy
  1. Ivy
  2. IVY-1074

Provide a 'required' attribute to ivy settings/properties element to control reaction to missing properties file

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.1.0-RC1
    • Component/s: Core
    • Labels:
      None

      Description

      we use ivy in our company and have our repository under version control which is checked out alongside our projects. our setup is designed to work when run from builds on an integration server, on developer's machines, and from under IDE plugins for IDEA and eclipse.

      because the repository checkout will vary based on environment, we expect that a property called 'libraries.root' is defined and points to the individual repository location. when run from ant, this value is provided as a build property. the issue arises when ivy is run from the plugins because 'libraries.root' is never set.

      to facilitate this, we use a single ivysettings.xml file which does the following:

      ivysettings.xml
      <ivysettings>
         ...
         <properties file="${ivy.settings.dir}/${user.name}.properties"/>
         ...
      </ivysettings>
      

      to load a properties file for the user where 'libraries.root' is defined.

      the problem is that there are cases, such as when run under the integration server, where the user will not have a properties file. in this case, the configuration blows up. i propose adding a 'required' attribute to control the reaction to a missing file:

      ivysettings.xml
      <ivysettings>
         ...
         <properties file="${ivy.settings.dir}/${user.name}.properties" required="false"/>
         ...
      </ivysettings>
      

        Issue Links

          Activity

          Maarten Coene added a comment -

          If I remember correctly, the current trunk version doesn't throw an error any longer if a properties file is missing.
          Would this solve your problem?

          Gilles Scokart added a comment -

          There is now just a trace at verbose level (to be aligned with the ant property task) saying the the file is not found.


            People

            • Assignee:
              Unassigned
              Reporter:
              Jeff Glatz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development