Uploaded image for project: 'IMPALA'
  1. IMPALA
  2. IMPALA-9501

Upgrade sqlparse to a version that supports python 3.0

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Impala 4.0
    • Component/s: Infrastructure
    • Labels:
      None
    • Epic Color:
      ghx-label-6

      Description

      The current version (0.1.19) was selected, per IMPALA-6999. because it's the last version to be compatible with python 2.6. However, it's not compatible with python 3.x.

      Traceback (most recent call last):
        File "/home/dknupp/Impala/shell/build/impala-shell-3.4.0-SNAPSHOT/impala_shell.py", line 37, in <module>
          import sqlparse
        File "<frozen importlib._bootstrap>", line 983, in _find_and_load
        File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
        File "<frozen importlib._bootstrap>", line 668, in _load_unlocked
        File "<frozen importlib._bootstrap>", line 638, in _load_backward_compatible
        File "/home/dknupp/Impala/shell/build/impala-shell-3.4.0-SNAPSHOT/ext-py/sqlparse-0.1.19-py2.7.egg/sqlparse/__init__.py", line 13, in <module>
        File "<frozen importlib._bootstrap>", line 983, in _find_and_load
        File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
        File "<frozen importlib._bootstrap>", line 668, in _load_unlocked
        File "<frozen importlib._bootstrap>", line 638, in _load_backward_compatible
        File "/home/dknupp/Impala/shell/build/impala-shell-3.4.0-SNAPSHOT/ext-py/sqlparse-0.1.19-py2.7.egg/sqlparse/engine/__init__.py", line 8, in <module>
        File "<frozen importlib._bootstrap>", line 983, in _find_and_load
        File "<frozen importlib._bootstrap>", line 963, in _find_and_load_unlocked
        File "<frozen importlib._bootstrap>", line 906, in _find_spec
        File "<frozen importlib._bootstrap_external>", line 1280, in find_spec
        File "<frozen importlib._bootstrap_external>", line 1254, in _get_spec
        File "<frozen importlib._bootstrap_external>", line 1235, in _legacy_get_spec
        File "<frozen importlib._bootstrap>", line 441, in spec_from_loader
        File "<frozen importlib._bootstrap_external>", line 594, in spec_from_file_location
        File "/home/dknupp/Impala/shell/build/impala-shell-3.4.0-SNAPSHOT/ext-py/sqlparse-0.1.19-py2.7.egg/sqlparse/lexer.py", line 84
          except Exception, err:
                          ^
      SyntaxError: invalid syntax
      

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              dknupp David Knupp
              Reporter:
              dknupp David Knupp

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment