Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-4583

Make Hive compile and run with JDK7

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.11.0
    • Fix Version/s: 0.13.0
    • Component/s: None
    • Labels:
      None

      Description

      This is an umbrella ticket to cover all issues related to supporting JDK 7 in HIVE. Many such issues are expected. Of course, JDK 6 needs to continue to work.

      The major obstacles on the way supporting JDK7 are:
      1. JDBC component needs to be upgraded because of JDBC interface changes in JDK7.
      2. DataNucleus needs to be upgraded because the current version doesn't support JDK7.
      3. Many test failures needs to be fixed. The majority of the failures are caused by JDK7 subtle behaviour change.
      4. Build needs to be changed to accommodate JDK7 compiler.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                xuefuz Xuefu Zhang
                Reporter:
                xuefuz Xuefu Zhang
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: