Uploaded image for project: 'Hive'
  1. Hive
  2. HIVE-22555

Upgrade ORC version to 1.5.8

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.0
    • Fix Version/s: 4.0.0
    • Component/s: ORC

      Description

      Hive currently depends on ORC 1.5.6. We need 1.5.8 upgrade for https://issues.apache.org/jira/browse/HIVE-22499

      ORC-1.5.7 includes https://issues.apache.org/jira/browse/ORC-361 . It causes some tests overriding MemoryManager to fail. These need to be addressed while upgrading.

       

        Attachments

        1. HIVE-22555.4.patch
          10 kB
          Mustafa İman
        2. HIVE-22555.3.patch
          10 kB
          Mustafa İman
        3. HIVE-22555.2.patch
          10 kB
          Mustafa İman
        4. HIVE-22555.2.patch
          10 kB
          Mustafa İman
        5. HIVE-22555.patch
          10 kB
          Mustafa İman
        6. HIVE-22555.patch
          10 kB
          Mustafa İman

          Issue Links

            Activity

              People

              • Assignee:
                mustafaiman Mustafa İman
                Reporter:
                mustafaiman Mustafa İman
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m