I had added these without much thought when writing the metrics-framework to test out the concept.
Looking back, these actually need of more investigation, as some are actually wrong or at least do not add much value. Wrong is the active-transaction, as actually each ObjectStore is a thread-local, and an aggregate number is what was meant. Open/committed/rollback need some investigation what really helps.
Goal is to remove these before the release to reduce confusion to users.