Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9677

Rename generationStampV1/generationStampV2 to legacyGenerationStamp/generationStamp

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha1
    • Component/s: namenode
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      comment from Kai Zheng in HDFS-9542:

      Just wonder if it's a good idea to rename: generationStampV1 => legacyGenerationStamp; generationStampV2 => generationStamp, similar for other variables, as we have legacy block and block.

      This jira plans to do this rename.

        Attachments

        1. HDFS-9677.000.patch
          42 kB
          Mingliang Liu
        2. HDFS-9677.001.patch
          29 kB
          Mingliang Liu
        3. HDFS-9677-branch-2.000.patch
          26 kB
          Mingliang Liu

          Activity

            People

            • Assignee:
              liuml07 Mingliang Liu
              Reporter:
              jingzhao Jing Zhao
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: