Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-9182

Cleanup the findbugs and other issues after HDFS EC merged to trunk.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: erasure-coding
    • Labels:
      None
    • Hadoop Flags:
      Reviewed
    1. HDFSS-9182.00.patch
      46 kB
      Uma Maheswara Rao G
    2. HDFSS-9182.01.patch
      46 kB
      Uma Maheswara Rao G

      Issue Links

        Activity

        umamaheswararao Uma Maheswara Rao G added a comment -

        Attached a patch to address the findbugs and release audit warnings.
        Changes are as follows:

        1) Added to excludes list for EI_EXPOSE_REP,EI_EXPOSE_REP2 type comments as as already added them in hadoop-hdfs-project.After moving to hfs-client project we should add file names explicitly.

        2) DFSOutputStream#currentPacket inconsistent synchronization because enqueueCurrentPacketFull is package scoped and a non synchronized method, here it is accessing currentPacket. This is the concern for findbags. Currently enqueueCurrentPacketFull called only in writeChunk which is already synchronized, so logically there is no issue. But to exclude such comments options to mention the field name which can avoid the comment, but the issue is it may suppress future warnings as well. So to make windbags happy I just made enqueueCurrentPacketFull synchronized, I think its ok.

        3) Merged the HDFS-7285 related CHANGES.txt to main CHANGES.txt.
        I also took chance to place two of the issue entries in CHANGES.txt, which was placed wrongly like HDFS lira entry in Common and vise versa.
        Following 2 are such type:
        HADOOP-11921. Enhance tests for erasure coders. (Kai Zheng)
        HDFS-8557. Allow to configure RS and XOR raw coders (Kai Zheng)

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        -1 patch 0m 0s The patch command could not apply the patch during dryrun.



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765129/HDFSS-9182.00.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 5f6edb3
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12807/console

        This message was automatically generated.

        jingzhao Jing Zhao added a comment -

        Thanks for all the fix, Uma Maheswara Rao G! The patch may need some rebase. Other than that looks good to me.

        umamaheswararao Uma Maheswara Rao G added a comment -

        Attached rebased patch, Thanks Jing, for review!

        hitliuyi Yi Liu added a comment -

        The patch looks good to me too. Thanks Uma Maheswara Rao G and Jing Zhao.
        Since the patch is straight, and also need to rebase if any committer commits a new patch, so how about running a local test-patch at the meantime, and attach the local report, if the Jenkins still fails, we can refer to the local report and rebase/commit it directly if the local test-patch successes?

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        -1 pre-patch 28m 16s Pre-patch trunk has 7 extant Findbugs (version 3.0.0) warnings.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 tests included 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        +1 javac 9m 8s There were no new javac warning messages.
        +1 javadoc 11m 47s There were no new javadoc warning messages.
        -1 release audit 0m 17s The applied patch generated 1 release audit warnings.
        +1 checkstyle 4m 39s There were no new checkstyle issues.
        -1 whitespace 0m 1s The patch has 26 line(s) that end in whitespace. Use git apply --whitespace=fix.
        +1 install 1m 41s mvn install still works.
        +1 eclipse:eclipse 0m 36s The patch built with eclipse:eclipse.
        -1 findbugs 7m 35s The patch appears to introduce 742 new Findbugs (version 3.0.0) warnings.
        -1 common tests 7m 7s Tests failed in hadoop-common.
        -1 hdfs tests 118m 55s Tests failed in hadoop-hdfs.
        +1 hdfs tests 0m 32s Tests passed in hadoop-hdfs-client.
            190m 38s  



        Reason Tests
        FindBugs module:hadoop-hdfs-client
          Inconsistent synchronization of org.apache.hadoop.hdfs.DFSOutputStream.currentPacket; locked 96% of time Unsynchronized access at DFSStripedOutputStream.java:96% of time Unsynchronized access at DFSStripedOutputStream.java:[line 535]
        Failed unit tests hadoop.security.ssl.TestReloadingX509TrustManager
          hadoop.hdfs.server.balancer.TestBalancer
          hadoop.hdfs.server.blockmanagement.TestBlockManager
        Timed out tests org.apache.hadoop.hdfs.server.balancer.TestBalancerWithMultipleNameNodes
          org.apache.hadoop.hdfs.server.namenode.ha.TestRetryCacheWithHA



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12765264/HDFSS-9182.01.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / 6d5713a
        Pre-patch Findbugs warnings https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/trunkFindbugsWarningshadoop-hdfs-client.html
        Release Audit https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/patchReleaseAuditProblems.txt
        whitespace https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/whitespace.txt
        Findbugs warnings https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs-client.html
        hadoop-common test log https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/testrun_hadoop-common.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/testrun_hadoop-hdfs.txt
        hadoop-hdfs-client test log https://builds.apache.org/job/PreCommit-HDFS-Build/12818/artifact/patchprocess/testrun_hadoop-hdfs-client.txt
        Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/12818/testReport/
        Java 1.7.0_55
        uname Linux asf907.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HDFS-Build/12818/console

        This message was automatically generated.

        umamaheswararao Uma Maheswara Rao G added a comment -

        Thanks for the reviews Jing Zhao and Yi Liu. I have just committed this to trunk.

        Here is the windbags count from above report: Total Warnings 0 0.00

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #8583 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8583/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #491 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/491/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #1228 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1228/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #499 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/499/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2435 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2435/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2403 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2403/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml
        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #465 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/465/)
        HDFS-9182. Cleanup the findbugs and other issues after HDFS EC merged to (umamahesh: rev 8b7339312cb06b7e021f8f9ea6e3a20ebf009af3)

        • hadoop-common-project/hadoop-common/CHANGES-HDFS-EC-7285.txt
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES-HDFS-EC-7285.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSStripedOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
        • hadoop-hdfs-project/hadoop-hdfs-client/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java
        • hadoop-hdfs-project/hadoop-hdfs-client/dev-support/findbugsExcludeFile.xml

          People

          • Assignee:
            umamaheswararao Uma Maheswara Rao G
            Reporter:
            hitliuyi Yi Liu
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development