Details

    • Type: Test Test
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Invalid
    • Affects Version/s: 0.20.1
    • Fix Version/s: 0.20.2
    • Component/s: None
    • Labels:
      None

      Description

      Two tests are currently failing on Hudson:

      chttp://hudson.zones.apache.org/hudson/view/Hadoop/job/Hadoop-20-Build/lastBuild/testReport

      >>> org.apache.hadoop.hdfs.TestDatanodeBlockScanner.testBlockCorruptionPolicy 0.0020 9
      >>> org.apache.hadoop.hdfs.server.namenode.TestFsck.testCorruptBlock

      HDFS-734 has already been filed for TestDatanodeBlockScanner.

        Issue Links

          Activity

          Suresh Srinivas added a comment -

          This bug is caused by the changes in HDFS-127

          Suresh Srinivas added a comment -

          Patch in HDFS-127 resets DFSInputStream.failures to zero. This causes infinite loop when DFSInputStream.read() is called for a block that has all replicas corrupt. Before this patch, based on failure count reaching a threshold, the read attempt was abandoned. Since failure count does not reach the threshold after the change in HDFS-127, DFSClient attempts to read the block in a loop.

          The patch from HDFS-127 should be reverted.

          Tsz Wo Nicholas Sze added a comment -

          After reverting HDSF-127 from 0.20, this issue becomes invalid.

          Thanks Eli and Suresh for discovering the problem.


            People

            • Assignee:
              Unassigned
              Reporter:
              Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development