Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-734

TestDatanodeBlockScanner times out in branch 0.20

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 0.20.2
    • Component/s: test
    • Labels:
      None

      Description

      When I test HDFS-723 on branch 0.20, TestDatanodeBlockScanner always times out with or without my patch to HDFS-723.

        Issue Links

          Activity

          Todd Lipcon added a comment -

          Patch available on HDFS-877. Once that's committed there, I'll backport to branch-20.

          Todd Lipcon added a comment -

          Upon further investigation, it looks like the HDFS-127 patch on branch-20 is what causes it there. On trunk and 21, it's the issue on HDFS-877.

          (I think... still sorting this out - strange that a single test timed out for two different reasons!)

          Todd Lipcon added a comment -

          This is fixed by Nicholas's revert of HDFS-127 on branch-0.20 (confirmed with a fresh checkout)


            People

            • Assignee:
              Tsz Wo Nicholas Sze
              Reporter:
              Hairong Kuang
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development