Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-7606

Missing null check in INodeFile#getBlocks()

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-alpha1
    • Fix Version/s: 2.7.0
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

          BlockInfo[] snapshotBlocks = diff == null ? getBlocks() : diff.getBlocks();
          if(snapshotBlocks != null)
            return snapshotBlocks;
          // Blocks are not in the current snapshot
          // Find next snapshot with blocks present or return current file blocks
          snapshotBlocks = getDiffs().findLaterSnapshotBlocks(diff.getSnapshotId());
      

      If diff is null and snapshotBlocks is null, NullPointerException would result from the call to diff.getSnapshotId().

      1. HDFS-7606.patch
        1 kB
        Byron Wong
      2. HDFS-7606-1.patch
        2 kB
        Chen He
      3. HDFS-7606.patch
        0.9 kB
        Byron Wong

        Issue Links

          Activity

          yuzhihong@gmail.com Ted Yu added a comment -

          In computeContentSummary():

                  counts.add(Content.LENGTH, diffs.getLast().getFileSize());
          

          diffs.getLast() should be checked against null.

          airbots Chen He added a comment -

          Hi Ted Yu, please correct me if I am wrong. There is a condition check in the INodeFile.computeContentSummary() whether "diffs.getLast()" is null or not

          final int n = diffs.asList().size();
          ....
          if (n > 0 && sf.isCurrentFileDeleted())

          { counts.add(Content.LENGTH, diffs.getLast().getFileSize()); }
          airbots Chen He added a comment -

          Do you mean the last element itself returned by diffs.getLast() is "null" ?

          yuzhihong@gmail.com Ted Yu added a comment -

          I was looking at getBlocks() method. In particular, line 435:

              snapshotBlocks = getDiffs().findLaterSnapshotBlocks(diff.getSnapshotId());
          
          shv Konstantin Shvachko added a comment -

          Ted, thanks for reporting. Sounds like a potential problem indeed.

          Byron Wong Byron Wong added a comment -

          Attached patch.
          Addesses the two spots that Ted Yu found.

          airbots Chen He added a comment -

          Hi Byron Wong, thank you for your work, it will be great if you can add the unit test that can reproduce the NPE

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12692408/HDFS-7606.patch
          against trunk revision 6464a89.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:

          org.apache.hadoop.hdfs.TestDatanodeReport

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9218//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9218//console

          This message is automatically generated.

          shv Konstantin Shvachko added a comment -

          Hey Chen, if I am not mistaken the NPE in getBlocks() is hypothetcial. I don't think Ted actually reproduced it or if it is reproducible with current code.

          Byron,

          1. should we just use snapshot instead of diff.getSnapshotId()? I think it is the same id.
          2. For computeContentSummary() the null check seems to be redundant, as n > 0 is guaranteed by the if statement.
          airbots Chen He added a comment -

          I am working on the unit test code to reproduce this NPE.

          airbots Chen He added a comment -

          To reproduce the NPE mentioned in this JIRA, in the INodeFile.getBlocks(), we just need to satisfy " diff=null "and "snapshotBlocks=null" before line 435 starts to execute. Then the diff.getSnapshotId() will cause NPE.

          airbots Chen He added a comment -

          NPE reproduced. Patch attached.

          shv Konstantin Shvachko added a comment -

          Hey Chen, what is the point of a unit test if it doesn't correspond to a real life scenario?

          Byron Wong Byron Wong added a comment -

          Added new patch.
          We can just use the snapshotId passed in by the method as Konstantin Shvachko pointed out.
          The other spot is covered by the n>0 check as mentioned by Chen He and Konstantin Shvachko.
          Chen He For the unit test, the case that you've mentioned is only possible in the case when the INodeFile's blocks are null. This case is only possible in the case when we call INodeFile#destroyAndCollectBlocks or FSDirConcatOp#unprotectedConcat (i.e. we can only have null blocks when we want to completely destroy the INodeFile). The only way to reproduce the NPE is by explicitly creating an INodeFile with null blocks as you've done in your test. I don't think we need to reproduce the NPE in a unit test if this is the case.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12692574/HDFS-7606-1.patch
          against trunk revision b6ff9c0.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          -1 eclipse:eclipse. The patch failed to build with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9224//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9224//console

          This message is automatically generated.

          airbots Chen He added a comment -

          (i.e. we can only have null blocks when we want to completely destroy the INodeFile)

          INodeFile with empty blocks is created and used for partial functionality verification in many test cases in TestINodeFile.java.

          The only way to reproduce the NPE is by explicitly creating an INodeFile with null blocks as you've done in your test. I don't think we need to reproduce the NPE in a unit test if this is the case.

          There is more than one way to reproduce NPE for this JIRA. Just follow the condition in my previous comments. To address a possible or potential error, as an ASF contributor, we need to reproduce it if we can do. Otherwise, how can you prove it is a bug or error that needs to be fixed?

          airbots Chen He added a comment -

          I am not intending to grab this JIRA. Maybe Konstantin Shvachko is right. But it will be great and persuasive to address a bug by reproduce it.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12692576/HDFS-7606.patch
          against trunk revision 3ab3a64.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/9234//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/9234//console

          This message is automatically generated.

          shv Konstantin Shvachko added a comment -

          Hi Chen you are absolutely right that as a general rule we as developers should do our best in reproducing bugs and capturing them in unit tests in order to prevent ourselves and other developers from making the same mistake again in the future.
          In this particular case

          1. I don't think that Ted had actually seen HDFS failing due to the NPE.
          2. I think it is an observation of a potential flaw based on examining the source code alone.
          3. And I don't think the NPE can be reproduced using any high level API calls to the NameNode.

          In summary I don't think any reasonable test case can be written here.
          It is just my opinion, and I very much hope this does not discourage you.
          Your contributions to the project in this and other directions are very much welcome.

          +1 on the latest patch.

          shv Konstantin Shvachko added a comment -

          I just committed this. Thank you Byron.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6879 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6879/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #76 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/76/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #810 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/810/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #73 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/73/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2008 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2008/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #77 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/77/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2027 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2027/)
          HDFS-7606. Fix potential NPE in INodeFile.getBlocks(). Contributed by Byron Wong. (shv: rev 60cbcff2f7363e5cc386284981cac67abc965ee7)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/server/namenode/INodeFile.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          shv Konstantin Shvachko added a comment -

          Merged to branch-2.


            People

            • Assignee:
              Byron Wong Byron Wong
              Reporter:
              yuzhihong@gmail.com Ted Yu
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development