Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      If cluster has different types of storage, it is useful to display the storage information per type.

      The information will be available via JMX (HDFS-7390)

      1. HDFS-7483.003.patch
        3 kB
        Haohui Mai
      2. HDFS-7483-001.patch
        14 kB
        Benoy Antony
      3. HDFS-7483-002.patch
        4 kB
        Benoy Antony
      4. overview.png
        185 kB
        Benoy Antony
      5. storagetypes_withnostorage.png
        115 kB
        Benoy Antony
      6. storagetypes.png
        123 kB
        Benoy Antony
      7. withOneStorageType.png
        36 kB
        Benoy Antony
      8. withTwoStorageType.png
        52 kB
        Benoy Antony

        Issue Links

          Activity

          benoyantony Benoy Antony added a comment -

          Attaching a patch which displays storage stats by storage type on the name node ui. The screen shots are attached.
          The patch has the following changes.

          1. The jmx for Blocktstats is enhanced by adding PercentRemaining and PercentUsed.
          2. Refactored header part of name node ui to header.html
          3. Added a page for storage types as shown in the screen shots and tested on a local cluster.

          wheat9 Haohui Mai added a comment -
          +  public float getPercentUsed() {
          +    return DFSUtilClient.getPercentUsed(capacityUsed, capacityTotal);
          +  }
          +
           
          +  public float getPercentRemaining() {
          +    return DFSUtilClient.getPercentRemaining(capacityRemaining,
          +        capacityTotal);
          +  }
          

          The client should calculate the percentage which allows more options on formatting.

          hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/header.html
          

          The duplication is actually by design for now to avoid partially loading pages. A better approach is to make it a dust template and to precompile it when building the artifacts, which requires some work on the build infrastructure.

          +  function load_storage_stats() {
          +    $.get(
          +      '/jmx?qry=Hadoop:service=NameNode,name=BlockStats',
          

          It should be loaded in the load_overview() function.

          arpitagarwal Arpit Agarwal added a comment -

          Hi Benoy Antony, thanks for this improvement. This would be great to have.

          Do you think it makes sense to add the Storage Types table to the overview page? It is hidden in the utilities tab. Also we can make the table sortable on individual columns in another Jira.

          These parameters look unused:

          +      float percentUsed, float percentRemaining) {
          

          I also agree with the suggestion of letting the client calculate the percentages. Not commenting on the html/js changes since Haohui has given feedback and he is way more familiar.

          benoyantony Benoy Antony added a comment -

          Thanks for the review and comments , Haohui Mai and Arpit Agarwal.

          Updated the patch based on the comments.

          1. Displays Storage type information on the overview screen. The table is displayed only if there are more than one storage types. Following screenshots are attached:
            • Overview page when there is only one storage type.
            • Overview page when there are two storage types.
          2. Added dust.js helper to calculate percentage on the client side.
          3. Removed an unnecessary System.out.println added by HDFS-7390.
          hadoopqa Hadoop QA added a comment -



          +1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 7m 39s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 35s There were no new javac warning messages.
          +1 release audit 0m 19s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 1m 25s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 19s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 2m 30s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 native 1m 7s Pre-build of native portion
          +1 hdfs tests 161m 21s Tests passed in hadoop-hdfs.
              183m 51s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12745066/HDFS-7483-002.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / 19295b3
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11685/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11685/testReport/
          Java 1.7.0_55
          uname Linux asf900.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11685/console

          This message was automatically generated.

          arpitagarwal Arpit Agarwal added a comment -

          +1 from me for the -002 patch. It looks like feedback from Haohui Mai is also addressed. Verified the changes in a pseudo-cluster and the display looks good to me.

          I will delay committing until tomorrow evening in case Haohui has further comments. Thanks a lot for contributing this improvement Benoy Antony.

          wheat9 Haohui Mai added a comment -
          +  var helpers = {
          +    'percentage': function(chunk, context, bodies, params) {
          +      var a = dust.helpers.tap(params.a, chunk, context);
          +      var b = dust.helpers.tap(params.b, chunk, context);
          +      var f = parseFloat(a)/parseFloat(b);
          +      return chunk.write(Math.round(f * 10000) / 100 + '%');
          +    }
          +  };
          +
          +  for(var key in helpers) {
          +	  dust.helpers[key] = helpers[key];
          +  }
          +
          

          A better approach is to do it through the math helper (http://www.dustjs.com/guides/dust-helpers/) and to format it with the fmt_percentage helper.

          benoyantony Benoy Antony added a comment -

          I don't think the suggested approach will work. But I could be wrong. Haohui Mai, Could you please provide a working code snippet for this approach ?

          benoyantony Benoy Antony added a comment -

          To add on, I had tried the approach while working on the patch. math is a helper whereas fmt_percentage is a filter. We cannot do something like "helper | filter" . Some helpers support a "filters" attribute. But math helper does not support "filters" attribute. So I could not reuse math helper and fmt_percentage filter. That's why I wrote a a new percentage helper.

          benoyantony Benoy Antony added a comment -

          Haohui Mai, As I mentioned, there is no good way of displaying percentage using math helper and fmt_percentage filter. If you have no further comments, I'll commit this patch by end of day tomorrow.

          wheat9 Haohui Mai added a comment -

          As I mentioned, there is no good way of displaying percentage using math helper and fmt_percentage filter.

          I haven't gotten the time to play around with it yet. If this is the case then the right thing to do is to calculate the percentage in the JavaScript and use the fmt_percentage helper in the template. Please see dfshealth.js for more references.

          benoyantony Benoy Antony added a comment -

          In the existing use cases of fmt_percentage, the percentage is already generated on the server side. I do not understand the approach that you are suggesting. Could you please provide me with a working snippet ?

          wheat9 Haohui Mai added a comment -

          Sorry for the delay.

          Benoy Antony, I uploaded the v3 patch to demonstrate the approach. The basic idea is to calculate the percentage using JavaScript and leave the templates to deal with the formatting only.

          benoyantony Benoy Antony added a comment -

          Nice. Thanks for the snippet. I like this approach.
          +1 pending jenkins.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 pre-patch 6m 0s Findbugs (version ) appears to be broken on trunk.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 53s There were no new javac warning messages.
          +1 release audit 0m 21s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 36s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 31s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          -1 findbugs 2m 41s The patch appears to introduce 1 new Findbugs (version 3.0.0) warnings.
          +1 native 1m 9s Pre-build of native portion
          -1 hdfs tests 168m 44s Tests failed in hadoop-hdfs.
              189m 30s  



          Reason Tests
          FindBugs module:hadoop-hdfs
          Failed unit tests hadoop.hdfs.server.namenode.ha.TestSeveralNameNodes
            hadoop.hdfs.TestAppendSnapshotTruncate
            hadoop.hdfs.server.namenode.ha.TestDFSUpgradeWithHA
            hadoop.hdfs.TestDistributedFileSystem
          Timed out tests org.apache.hadoop.cli.TestHDFSCLI



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12746206/HDFS-7483.003.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / e4f7562
          Findbugs warnings https://builds.apache.org/job/PreCommit-HDFS-Build/11757/artifact/patchprocess/newPatchFindbugsWarningshadoop-hdfs.html
          hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HDFS-Build/11757/artifact/patchprocess/testrun_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/11757/testReport/
          Java 1.7.0_55
          uname Linux asf904.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/11757/console

          This message was automatically generated.

          wheat9 Haohui Mai added a comment -

          I've committed the patch to trunk and branch-2. Thanks Benoy Antony for the contribution.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #8190 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8190/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #263 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/263/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #993 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/993/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2190 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2190/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #252 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/252/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #260 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/260/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #2209 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2209/)
          HDFS-7483. Display information per tier on the Namenode UI. Contributed by Benoy Antony and Haohui Mai. (wheat9: rev df1e8ce44a4716b2cb4ff3d161d7df8081572290)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.js
          • hadoop-hdfs-project/hadoop-hdfs/src/main/webapps/hdfs/dfshealth.html
          • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestBlockStatsMXBean.java

            People

            • Assignee:
              benoyantony Benoy Antony
              Reporter:
              benoyantony Benoy Antony
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development