Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently 15 tests are failing during the build. They all are complaining about "Server returned HTTP response code: 500 for URL:" where the URL varies.

        Issue Links

          Activity

          Owen O'Malley added a comment -

          I believe this is closed now.

          Tsz Wo Nicholas Sze added a comment -

          Created HADOOP-6281.

          Tsz Wo Nicholas Sze added a comment -

          Look like that the cause is

          2009-09-23 12:51:13,090 ERROR mortbay.log (?:invoke0(?)) - /dfshealth.jsp
          java.lang.NullPointerException
          	at org.apache.hadoop.http.HtmlQuoting.quoteHtmlChars(HtmlQuoting.java:95)
          	at org.apache.hadoop.http.HttpServer$QuotingInputFilter$RequestQuoter.getParameter(HttpServer.java:570)
          	at org.apache.hadoop.hdfs.server.namenode.NamenodeJspHelper$HealthJsp.generateHealthReport(NamenodeJspHelper.java:168)
          	at org.apache.hadoop.hdfs.server.namenode.dfshealth_jsp._jspService(dfshealth_jsp.java:96)
          	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
          	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
          	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:502)
          	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1124)
          	at org.apache.hadoop.http.HttpServer$QuotingInputFilter.doFilter(HttpServer.java:613)
          	at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1115)
          	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:361)
          	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
          	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
          	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
          	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:417)
          	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
          	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
          	at org.mortbay.jetty.Server.handle(Server.java:324)
          	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:534)
          	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:864)
          	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:533)
          	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:207)
          	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:403)
          	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
          	at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:522)
          
          gary murry added a comment -

          The test that are failing (http://hudson.zones.apache.org/hudson/view/Hadoop/job/Hadoop-Hdfs-trunk/92/testReport/)

          • org.apache.hadoop.hdfs.TestMissingBlocksAlert.testMissingBlocksAlert
          • org.apache.hadoop.hdfs.server.namenode.TestBackupNode.testCheckpoint
          • org.apache.hadoop.hdfs.server.namenode.TestCheckpoint.testCheckpoint
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsck
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsckNonExistent
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsckPermission
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsckMove
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsckOpenFiles
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testCorruptBlock
          • org.apache.hadoop.hdfs.server.namenode.TestFsck.testFsckError
          • org.apache.hadoop.hdfs.server.namenode.TestNameEditsConfigs.testNameEditsConfigs
          • org.apache.hadoop.hdfs.server.namenode.TestStartup.testChkpointStartup2
          • org.apache.hadoop.hdfs.server.namenode.TestStartup.testChkpointStartup1
          • org.apache.hadoop.hdfs.server.namenode.TestStartup.testSNNStartup
          • org.apache.hadoop.hdfs.server.namenode.TestStorageRestore.testStorageRestore

            People

            • Assignee:
              Owen O'Malley
              Reporter:
              gary murry
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development