Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-6408

Remove redundant definitions in log4j.properties

    Details

    • Type: Test
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Following definitions in 'hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties' are defined twice and should be removed:

      log4j.appender.ROLLINGFILE.layout=org.apache.log4j.PatternLayout
      log4j.appender.ROLLINGFILE.layout.ConversionPattern=%d{ISO8601} - %-5p [%t:%C{1}@%L] - %m%n
      
      1. HDFS-6408-002.patch
        0.7 kB
        Akira Ajisaka
      2. HDFS-6408.patch
        0.7 kB
        Abhiraj Butala

        Issue Links

          Activity

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #2080 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2080/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #139 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/139/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2098 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2098/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #148 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/148/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #882 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/882/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #148 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/148/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          hadoopqa Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12708070/HDFS-6408-002.patch
          against trunk revision 257c77f.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/10105//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/10105//console

          This message is automatically generated.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #7456 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7456/)
          HDFS-6408. Remove redundant definitions in log4j.properties. Contributed by Abhiraj Butala. (aajisaka: rev 232eca944a721c62f37e9012546a7fa814da6e01)

          • hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal/src/test/resources/log4j.properties
          • hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          ajisakaa Akira Ajisaka added a comment -

          Committed v2 patch to trunk and branch-2. Thanks Abhiraj Butala for the contribution!

          ajisakaa Akira Ajisaka added a comment -

          The conflict is caused by HDFS-6263. Rebasing the patch and will commit it.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12645399/HDFS-6408.patch
          against trunk revision 257c77f.

          -1 patch. The patch command could not apply the patch.

          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/10104//console

          This message is automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          +1 (binding). The test failure looks unrelated.

          hadoopqa Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12645399/HDFS-6408.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal:

          org.apache.hadoop.contrib.bkjournal.TestBookKeeperHACheckpoints

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6929//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6929//console

          This message is automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          +1 (non-binding).

          abutala Abhiraj Butala added a comment -

          Attaching a simple patch to remove the redundant definitions.


            People

            • Assignee:
              abutala Abhiraj Butala
              Reporter:
              abutala Abhiraj Butala
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development