Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-626

NameNode.complete(..) may throw NullPointerException

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: namenode
    • Labels:
      None

      Description

      We observe it in one of our clusters

      2009-09-09 19:28:37,530 INFO org.apache.hadoop.ipc.Server: IPC Server handler 11 on 8020, call
      complete(/path/to/a/file, DFSClient_attempt_200909091810_0062_r_000000_0) from xx.xx.xx.xx:xxxxx:
      error: java.io.IOException: java.lang.NullPointerException
      

        Issue Links

          Activity

          qwertymaniac Harsh J added a comment -

          This has gone stale. Haven't seen this in a while, resolving.

          szetszwo Tsz Wo Nicholas Sze added a comment -

          Sure, we should create a test after we understand the cause of the NPE.

          cos Konstantin Boudnik added a comment -

          Should we create a regression test using fault-injection framework?


            People

            • Assignee:
              Unassigned
              Reporter:
              szetszwo Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development