Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-6257

TestCacheDirectives#testExceedsCapacity fails occasionally

    Details

    • Type: Test Test
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.5.0
    • Component/s: caching
    • Labels:
      None
    • Target Version/s:

      Description

      From https://builds.apache.org/job/Hadoop-Hdfs-trunk/1736/ :

      REGRESSION: org.apache.hadoop.hdfs.server.namenode.TestCacheDirectives.testExceedsCapacity

      Error Message:
      Namenode should not send extra CACHE commands expected:<0> but was:<2>
      
      Stack Trace:
      java.lang.AssertionError: Namenode should not send extra CACHE commands expected:<0> but was:<2>
              at org.junit.Assert.fail(Assert.java:93)
              at org.junit.Assert.failNotEquals(Assert.java:647)
              at org.junit.Assert.assertEquals(Assert.java:128)
              at org.junit.Assert.assertEquals(Assert.java:472)
              at org.apache.hadoop.hdfs.server.namenode.TestCacheDirectives.testExceedsCapacity(TestCacheDirectives.java:1419)
      
      1. HDFS-6257.001.patch
        3 kB
        Colin Patrick McCabe

        Issue Links

          Activity

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1797 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1797/)
          HDFS-6257. TestCacheDirectives#testExceedsCapacity fails occasionally (cmccabe) (cmccabe: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1601473)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCacheDirectives.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1770 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1770/)
          HDFS-6257. TestCacheDirectives#testExceedsCapacity fails occasionally (cmccabe) (cmccabe: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1601473)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCacheDirectives.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #579 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/579/)
          HDFS-6257. TestCacheDirectives#testExceedsCapacity fails occasionally (cmccabe) (cmccabe: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1601473)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCacheDirectives.java
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #5668 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5668/)
          HDFS-6257. TestCacheDirectives#testExceedsCapacity fails occasionally (cmccabe) (cmccabe: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1601473)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/namenode/TestCacheDirectives.java
          Colin Patrick McCabe added a comment -

          committed, thanks

          Andrew Wang added a comment -

          Hmm, I guess good enough. +1 thanks colin.

          Colin Patrick McCabe added a comment -

          The current check should always succeed if the code being tested is correct, so it's not racy in that sense. We could wait for more DN cache reports, but since the DNs are full they shouldn't change. Since we test the cache reports elsewhere, I think it's probably fine as-is, what do you think?

          Andrew Wang added a comment -

          Idea look good, the current check definitely seems racy. Only q, maybe we should try and check more deterministically, e.g. pause DN cache reports and wait for a few refresh intervals (1s each) before doing the check.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12648692/HDFS-6257.001.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7054//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7054//console

          This message is automatically generated.


            People

            • Assignee:
              Colin Patrick McCabe
              Reporter:
              Ted Yu
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development