Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0, 2.2.0
    • Fix Version/s: 2.4.0
    • Component/s: tools
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Executing -step or/and -maxSize option will get the following error:

      $ hdfs oiv -p FileDistribution -step 102400 -i input -o output
      Error parsing command-line options:
      Usage: bin/hdfs oiv [OPTIONS] -i INPUTFILE -o OUTPUTFILE
      
      1. HDFS-5866.5.patch
        5 kB
        Akira AJISAKA
      2. HDFS-5866.4.patch
        5 kB
        Akira AJISAKA
      3. HDFS-5866.3.patch
        5 kB
        Akira AJISAKA
      4. HDFS-5866.2.patch
        7 kB
        Akira AJISAKA
      5. HDFS-5866.patch
        2 kB
        Akira AJISAKA

        Issue Links

          Activity

          Akira AJISAKA created issue -
          Akira AJISAKA made changes -
          Field Original Value New Value
          Component/s tools [ 12312944 ]
          Akira AJISAKA made changes -
          Affects Version/s 3.0.0 [ 12320356 ]
          Target Version/s 2.4.0 [ 12326143 ] 3.0.0 [ 12320356 ]
          Akira AJISAKA made changes -
          Attachment HDFS-5866.patch [ 12628609 ]
          Akira AJISAKA made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Akira AJISAKA added a comment -

          Attaching a patch to enable these options.
          I built with the patch and confirmed the options worked.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12628609/HDFS-5866.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6133//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6133//console

          This message is automatically generated.

          Akira AJISAKA added a comment -

          Add test for these options, and fixed to output actual file size.
          Now a file size is multiplied by the replication factor when using FileDistribution processor.

          Akira AJISAKA made changes -
          Attachment HDFS-5866.2.patch [ 12629161 ]
          Akira AJISAKA added a comment -

          Now a file size is multiplied by the replication factor when using FileDistribution processor.

          Created a separate issue (HDFS-5956). I'll split the patch.

          Akira AJISAKA made changes -
          Status Patch Available [ 10002 ] Open [ 1 ]
          Akira AJISAKA made changes -
          Link This issue is blocked by HDFS-5956 [ HDFS-5956 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12629161/HDFS-5866.2.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6162//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6162//console

          This message is automatically generated.

          Akira AJISAKA added a comment -

          Attaching a patch for the latest trunk.

          Akira AJISAKA made changes -
          Attachment HDFS-5866.3.patch [ 12631073 ]
          Akira AJISAKA made changes -
          Link This issue is blocked by HDFS-5956 [ HDFS-5956 ]
          Akira AJISAKA made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Target Version/s 3.0.0 [ 12320356 ] 2.4.0 [ 12326143 ]
          Akira AJISAKA made changes -
          Link This issue relates to HDFS-5956 [ HDFS-5956 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12631073/HDFS-5866.3.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6238//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6238//console

          This message is automatically generated.

          Haohui Mai added a comment -

          It seems to me that the unit test only needs to test whether it accepts the command line.

          I suggest moving the code from the main() function into a run() function, which returns an integer as a status code. Then the unit test can looks like this:

          int status = OfflineImageViewerPB.run(new String[] { "-i", originalFsImage.getAbsolutePath(), "-o", "-", "-p", "FileDistribution", "-maxSize", "512", "-step", "8"});
          Assert.assertEquals(0, status);
          
          Akira AJISAKA made changes -
          Attachment HDFS-5866.4.patch [ 12631871 ]
          Akira AJISAKA added a comment -

          Thanks for the review. I attached a new patch.

          Haohui Mai added a comment -

          The v4 patch looks mostly good.

          +      return 1;
          

          Let's return -1 instead of 1, since by convention a tool returns negative status codes to indicate errors.

          Nit: trailing whitespace.

              int status = OfflineImageViewerPB.run(new String[] {"-i", 
          

          +1 once addressed.

          Akira AJISAKA added a comment -

          Attaching a new patch.

          Akira AJISAKA made changes -
          Attachment HDFS-5866.5.patch [ 12631881 ]
          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12631871/HDFS-5866.4.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6268//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6268//console

          This message is automatically generated.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12631881/HDFS-5866.5.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-hdfs-project/hadoop-hdfs.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/6270//testReport/
          Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6270//console

          This message is automatically generated.

          Haohui Mai added a comment -

          I've committed it into trunk, branch-2, and branch-2.4. Thanks Akira AJISAKA for the contribution.

          Haohui Mai made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Hadoop Flags Reviewed [ 10343 ]
          Fix Version/s 2.4.0 [ 12326143 ]
          Resolution Fixed [ 1 ]
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-trunk-Commit #5254 (See https://builds.apache.org/job/Hadoop-trunk-Commit/5254/)
          HDFS-5866. '-maxSize' and '-step' option fail in OfflineImageViewer. Contributed by Akira Ajisaka. (wheat9: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573694)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/FileDistributionCalculator.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/OfflineImageViewerPB.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/TestOfflineImageViewer.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #499 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/499/)
          HDFS-5866. '-maxSize' and '-step' option fail in OfflineImageViewer. Contributed by Akira Ajisaka. (wheat9: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573694)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/FileDistributionCalculator.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/OfflineImageViewerPB.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/TestOfflineImageViewer.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1691 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1691/)
          HDFS-5866. '-maxSize' and '-step' option fail in OfflineImageViewer. Contributed by Akira Ajisaka. (wheat9: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573694)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/FileDistributionCalculator.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/OfflineImageViewerPB.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/TestOfflineImageViewer.java
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk #1716 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1716/)
          HDFS-5866. '-maxSize' and '-step' option fail in OfflineImageViewer. Contributed by Akira Ajisaka. (wheat9: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1573694)

          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/CHANGES.txt
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/FileDistributionCalculator.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/OfflineImageViewerPB.java
          • /hadoop/common/trunk/hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/tools/offlineImageViewer/TestOfflineImageViewer.java
          Arun C Murthy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Patch Available Patch Available Open Open
          2d 25m 1 Akira AJISAKA 15/Feb/14 00:17
          Open Open Patch Available Patch Available
          20d 12h 50m 2 Akira AJISAKA 25/Feb/14 22:25
          Patch Available Patch Available Resolved Resolved
          5d 21h 21m 1 Haohui Mai 03/Mar/14 19:46
          Resolved Resolved Closed Closed
          37d 17h 25m 1 Arun C Murthy 10/Apr/14 14:11

            People

            • Assignee:
              Akira AJISAKA
              Reporter:
              Akira AJISAKA
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development