Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-489

Updated TestHDFSCLI for changes from HADOOP-6139

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      HADOOP-6139 changed the output of the rm/rmr console text. The unit test for this is in hdfs, so TestHDFSCLI needs to be updated for the new output. Patch shortly.

      1. HDFS-489.patch
        2 kB
        Jakob Homan

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #23 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Hdfs-trunk/23/)
          . Update TestHDFSCLI for the -skipTrash option in rm. Contributed by Jakob Homan

          Tsz Wo Nicholas Sze added a comment -

          I have committed this. Thanks, Jakob!

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12413353/HDFS-489.patch
          against trunk revision 793753.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 5 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/19/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/19/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/19/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hdfs-Patch-vesta.apache.org/19/console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good.

          Jakob Homan added a comment -

          submitting patch

          Jakob Homan added a comment -

          Patch fixes TestHDFSCLI with new expected behavior.

          Even though the original patch was backported to 20, this particular test case was added after 20, so there is no need for a 20 port of this patch.

          It looks like the commons jar has been updated in the git repo, so TestHDFSCLI is currently breaking with this behavior and should be fixed.

          Hudson will complain about no tests but this does modify a test.


            People

            • Assignee:
              Jakob Homan
              Reporter:
              Jakob Homan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development