Details

    • Type: Test Test
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.0
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Fix tests broken by refactoring.

      1. HDFS-1933.patch
        2 kB
        Daryn Sharp
      2. HDFS-1933-2.patch
        2 kB
        Daryn Sharp

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #673 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk/673/)

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #658 (See https://builds.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/658/)

          Todd Lipcon added a comment -

          Yep, I must have not hit the "ant clean" button hard enough last time. I got it to pass now. Committed to trunk, thanks Daryn!

          Daryn Sharp added a comment -

          Odd. I just reran HDFS-1933-2.patch against hadoop-common's trunk and the test passed. Would you please double check?

          Todd Lipcon added a comment -

          I seem to be getting the following failure even with the hadoop-side patch:

          Testcase: testDFSShell took 0.961 sec
          FAILED
          expected:<1> but was:<-1>
          junit.framework.AssertionFailedError: expected:<1> but was:<-1>
          at org.apache.hadoop.hdfs.TestDFSShell.testDFSShell(TestDFSShell.java:1055)

          Daryn Sharp added a comment -

          Phew. I was trying to split up the giant test, which would require sharing a mini cluster object across tests, which incidentally would drastically reduce the runtime of the tests, but resetting the cluster and/or tearing it down was turning into a rabbit hole...

          In this patch I simply removed the errant tab as requested. Thanks!

          Todd Lipcon added a comment -

          Ah, fair enough... might as well be internally consistent. I don't think it lets all tests run, since after any of the catch clauses, it will fail on the next assert since the variable wouldn't be set to a correct return code. Patch looks good except there is one tab character:
          + args = new String[2];

          Daryn Sharp added a comment -

          I just followed the pattern that was there, but I can change it. I suppose it's to let all the tests run since they are all part of one giant junit test.

          Todd Lipcon added a comment -

          In the tests, why do we need the try..catch around all of the invocations? It seems to me that we don't expect anything to be thrown, so we should just let the exception out so it will fail the test if thrown.

          Aaron T. Myers added a comment -

          +1. Patch looks good to me. Thanks, Daryn.

          Daryn Sharp added a comment -

          (Mishap caused by forgetting to mvn-install hadoop-common before running hdfs tests...)

          No changes necessary to this patch. I fixed the related HADOOP-7285's patch to return the correct exit codes expected by these test changes. Note that other test failures are not related to the "test" command.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479047/HDFS-1933.patch
          against trunk revision 1102513.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these core unit tests:
          org.apache.hadoop.cli.TestHDFSCLI
          org.apache.hadoop.hdfs.server.datanode.TestBlockRecovery
          org.apache.hadoop.hdfs.TestDFSShell
          org.apache.hadoop.hdfs.TestDFSStorageStateRecovery
          org.apache.hadoop.hdfs.TestFileConcurrentReader
          org.apache.hadoop.hdfs.TestInjectionForSimulatedStorage
          org.apache.hadoop.tools.TestJMXGet

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/510//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/510//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HDFS-Build/510//console

          This message is automatically generated.


            People

            • Assignee:
              Daryn Sharp
              Reporter:
              Daryn Sharp
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development