Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.0
    • Component/s: fs
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Need to refactor to conform to FsCommand subclass.

      1. HADOOP-7285-3.patch
        9 kB
        Daryn Sharp
      2. HADOOP-7285-2.patch
        9 kB
        Daryn Sharp
      3. HADOOP-7285.patch
        8 kB
        Daryn Sharp

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #601 (See https://builds.apache.org/hudson/job/Hadoop-Common-trunk-Commit/601/)

          Hudson added a comment -

          Integrated in Hadoop-Common-trunk #688 (See https://builds.apache.org/hudson/job/Hadoop-Common-trunk/688/)
          HADOOP-7285. Refactor the test command to conform to new FsCommand class. Contributed by Daryn Sharp.

          Todd Lipcon added a comment -

          Committed to trunk. Thanks, Daryn!

          Have we been considering these changes to be incompatible changes, since they change the error output?

          Todd Lipcon added a comment -

          +1, looks good to me.

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479147/HADOOP-7285-3.patch
          against trunk revision 1102123.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/448//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/448//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/448//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          Change "flag" from protected to private as requested. Thanks, Aaron!

          Aaron T. Myers added a comment -

          Yup. Might as well be private if you don't intend Test to be subclassed.

          Daryn Sharp added a comment -

          Good question. I suppose there is no reason. Shall I change it?

          Aaron T. Myers added a comment -

          +1. Patch looks good, Daryn.

          One question: why is the flag instance variable in o.a.h.fs.shell.Test protected, instead of private?

          Hadoop QA added a comment -

          +1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479132/HADOOP-7285-2.patch
          against trunk revision 1102123.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/446//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/446//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/446//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          (Mishap caused by forgetting to mvn-install before running hdfs tests...)

          Don't throw FNF exception, just display the error, so correct exit code is returned and the tests in HDFS-1933 will pass.

          Also removed unrelated and unused DelayedExceptionThrowing that is causing a findbugs warning.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12479046/HADOOP-7285.patch
          against trunk revision 1102123.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 6 new or modified tests.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          -1 findbugs. The patch appears to introduce 1 new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed core unit tests.

          +1 contrib tests. The patch passed contrib unit tests.

          +1 system test framework. The patch passed system test framework compile.

          Test results: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/443//testReport/
          Findbugs warnings: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/443//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Console output: https://builds.apache.org/hudson/job/PreCommit-HADOOP-Build/443//console

          This message is automatically generated.


            People

            • Assignee:
              Daryn Sharp
              Reporter:
              Daryn Sharp
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development