Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.22.0
    • Fix Version/s: 0.22.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The jsvc specified in build.xml 404s, causing the build to fail, because version 1.0.2 has been archived. Let's update the url, not sure we want to move to 1.0.3 or play the game where the build breaks with every jsvc dot release.

      1. hdfs-1352-1.patch
        0.7 kB
        Eli Collins
      2. HDFS-1352-y20.patch
        0.6 kB
        Jakob Homan

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          1m 24s 1 Eli Collins 24/Aug/10 15:50
          Patch Available Patch Available Resolved Resolved
          2d 3h 29m 1 Jakob Homan 26/Aug/10 19:19
          Resolved Resolved Closed Closed
          472d 11h 59m 1 Konstantin Shvachko 12/Dec/11 06:18
          Konstantin Shvachko made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #374 (See https://hudson.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/374/)
          HDFS-1352. Fix jsvc.location. Contributed by Eli Collins.

          Jakob Homan made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Jakob Homan added a comment -

          I've committed this. Resolving as fixed. Thanks, Eli. Now that 1.0.2 has been archived, its location won't change again and this shouldn't re-occur.

          Jakob Homan added a comment -

          Verified manually. Going to commit.

          Luke Lu added a comment -

          Note, since the build failure is caused by an external change in an external dependency, the test-patch would fail due to trunk build failure.
          +1 for committing this patch, as all other hdfs patches depend on this one.

          Konstantin Boudnik made changes -
          Link This issue blocks HDFS-1355 [ HDFS-1355 ]
          Jakob Homan added a comment -

          ^but doesn't support^but git doesn't support

          ... sigh.

          Jakob Homan added a comment -

          HDFS uses svn:externals to fetch the test-patch script from Core, but doesn't support svn:externals. So you either need to run tp from an svn checkout or (what I do) just manually copy the script over to ./src/test/bin/test-patch.sh

          Eli Collins added a comment -

          Hm, looks like there's no test-patch in hdfs, does this need to be modified to use HADOOP_COMMON_HOME?

          hdfs3 (trunk)$ ant-test-patch  temp.patch 
          ...
          test-patch:
               [exec] bash: /home/eli/src/hdfs3/src/test/bin/test-patch.sh: No such file or directory
          
          Jakob Homan added a comment -

          Eli, with Hudson missing at sea, can you run test-patch? It should be fine, but we should double check. Tests don't need to be run... After that I'll commit it.

          Jakob Homan made changes -
          Attachment HDFS-1352-y20.patch [ 12453064 ]
          Jakob Homan added a comment -

          Patch for y20. Not for commit. I'd like to stick with 1.0.2, since that's the version we're using in production and have verified it works.

          Jakob Homan made changes -
          Hadoop Flags [Reviewed]
          Jakob Homan added a comment -

          +1

          Eli Collins made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Assignee Eli Collins [ eli ]
          Eli Collins made changes -
          Field Original Value New Value
          Attachment hdfs-1352-1.patch [ 12452937 ]
          Eli Collins added a comment -

          Patch attached.

          Eli Collins created issue -

            People

            • Assignee:
              Eli Collins
              Reporter:
              Eli Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development