Hadoop HDFS
  1. Hadoop HDFS
  2. HDFS-1343

Instrumented build should be concentrated in one build area

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.21.0
    • Fix Version/s: 0.21.1
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Current instrumented build is inefficient in a sense that part of it is build under build-fi and another part is under build-fi/system.
      This doubles the time of some classes and tests compilation. And needed to be fixed.

      1. hdfs-1343.patch
        3 kB
        Konstantin Boudnik
      2. hdfs-1343.patch
        2 kB
        Konstantin Boudnik

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #409 (See https://hudson.apache.org/hudson/job/Hadoop-Hdfs-trunk-Commit/409/)
          HDFS-1343. Instrumented build should be concentrated in one build area. Contributed by Konstantin Boudnik.

          Konstantin Boudnik added a comment -

          I have just committed this both to trunk and 0.21 branch

          Konstantin Boudnik added a comment -

          Refit after HDFS-1444 fix (only one parameter's name is changed). The patch as the same as before: I checked the content of generated jar files and made sure that HDFS system tests are running on real cluster. This seems ready for commit.

          Chris Douglas added a comment -

          +1

          This is the mirror of MAPREDUCE-1897

          Konstantin Boudnik added a comment -

          As Apache Hudson doesn't function for a few weeks now I have ran test-patch.sh locally:

          -1 overall.
          
              +1 @author.  The patch does not contain any @author tags.
          
              +1 tests included.  The patch appears to include 6 new or modified tests.
          
              -1 javadoc.  The javadoc tool appears to have generated 1 warning messages.
          
              +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
          
              +1 findbugs.  The patch does not introduce any new Findbugs warnings.
          
              +1 release audit.  The applied patch does not increase the total number of release audit warnings.
          
              +1 system tests framework.  The patch passed system tests framework compile.
          

          The warning in question is caused by

            [javadoc] /homes/cos/work/git/hdfs/src/java/org/apache/hadoop/hdfs/server/datanode/metrics/FSDatasetMBean.java:40: warning - Tag @see: reference not found: org.apache.hadoop.h
          dfs.server.datanode.metrics.DataNodeStatisticsMBean
          

          Which clearly isn't related to the scope of the patch.

          run-commit-test shows no surprises: all passed but org.apache.hadoop.hdfs.TestFileStatus which I think has been broken for a while now.
          I'll be committing this after formal review process is over.

          Konstantin Boudnik added a comment -

          Here's the patch.


            People

            • Assignee:
              Konstantin Boudnik
              Reporter:
              Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development