Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-10816

TestComputeInvalidateWork#testDatanodeReRegistration fails due to race between test and replication monitor

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha4, 2.8.2
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      java.lang.AssertionError: Expected invalidate blocks to be the number of DNs expected:<3> but was:<2>
      	at org.junit.Assert.fail(Assert.java:88)
      	at org.junit.Assert.failNotEquals(Assert.java:743)
      	at org.junit.Assert.assertEquals(Assert.java:118)
      	at org.junit.Assert.assertEquals(Assert.java:555)
      	at org.apache.hadoop.hdfs.server.blockmanagement.TestComputeInvalidateWork.testDatanodeReRegistration(TestComputeInvalidateWork.java:160)
      

      The test fails because of a race condition between the test and the replication monitor. The default replication monitor interval is 3 seconds, which is just about how long the test normally takes to run. The test deletes a file and then subsequently gets the namesystem writelock. However, if the replication monitor fires in between those two instructions, the test will fail as it will itself invalidate one of the blocks. This can be easily reproduced by removing the sleep() in the ReplicationMonitor's run() method in BlockManager.java, so that the replication monitor executes as quickly as possible and exacerbates the race.

      To fix the test all that needs to be done is to turn off the replication monitor.

      1. HDFS-10816.001.patch
        0.9 kB
        Eric Badger
      2. HDFS-10816.002.patch
        0.9 kB
        Kihwal Lee
      3. HDFS-10816.002.patch
        0.9 kB
        Eric Badger
      4. HDFS-10816-branch-2.002.patch
        0.9 kB
        Eric Badger

        Issue Links

          Activity

          ebadger Eric Badger added a comment -

          Attaching patch to stop the replication monitor in the @Before method of the test class. All of the tests are testing portions of the replication monitor code, so it would be prudent for the replication monitor to not run.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 19s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 8m 55s trunk passed
          +1 compile 0m 59s trunk passed
          +1 checkstyle 0m 31s trunk passed
          +1 mvnsite 1m 11s trunk passed
          +1 mvneclipse 0m 13s trunk passed
          +1 findbugs 2m 1s trunk passed
          +1 javadoc 1m 0s trunk passed
          +1 mvninstall 1m 0s the patch passed
          +1 compile 0m 43s the patch passed
          +1 javac 0m 43s the patch passed
          +1 checkstyle 0m 24s the patch passed
          +1 mvnsite 0m 49s the patch passed
          +1 mvneclipse 0m 10s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 1m 49s the patch passed
          +1 javadoc 0m 54s the patch passed
          -1 unit 76m 21s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 22s The patch does not generate ASF License warnings.
          99m 3s



          Reason Tests
          Failed junit tests hadoop.hdfs.TestPersistBlocks



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:9560f25
          JIRA Issue HDFS-10816
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12826196/HDFS-10816.001.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 0538865c37d7 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / af50860
          Default Java 1.8.0_101
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/16577/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/16577/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/16577/console
          Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          ebadger Eric Badger added a comment -

          The test failure is unrelated to the patch

          shahrs87 Rushabh S Shah added a comment -

          Eric Badger: Thanks for reporting and analyzing the failure.
          This test broke in our internal build recently.
          Below are the relevant logs:

          2016-08-29 01:54:49,332 INFO  impl.RamDiskAsyncLazyPersistService (RamDiskAsyncLazyPersistService.java:shutdown(169)) - All async lazy persist service threads have been shut down
          2016-08-29 01:54:49,336 INFO  datanode.DataNode (DataNode.java:shutdown(1791)) - Shutdown complete.
          2016-08-29 01:54:49,347 INFO  BlockStateChange (BlockManager.java:addToInvalidates(1228)) - BLOCK* addToInvalidates: blk_1073741825_1001 127.0.0.1:57662 127.0.0.1:43137 127.0.0.1:59637 
          2016-08-29 01:54:49,349 INFO  FSNamesystem.audit (FSNamesystem.java:logAuditMessage(8476)) - allowed=true	ugi=tortuga (auth:SIMPLE)	ip=/127.0.0.1	cmd=delete	src=/testRR	dst=null	perm=null	proto=rpc
          2016-08-29 01:54:49,350 INFO  BlockStateChange (BlockManager.java:invalidateWorkForOneNode(3582)) - BLOCK* BlockManager: ask 127.0.0.1:59637 to delete [blk_1073741825_1001]
          2016-08-29 01:54:49,355 INFO  hdfs.MiniDFSCluster (MiniDFSCluster.java:shutdown(1725)) - Shutting down the Mini HDFS Cluster
          

          2016-08-29 01:54:49,336 INFO datanode.DataNode (DataNode.java:shutdown(1791)) - Shutdown complete.

          This line corresponds to shutting down the last datanode.

          2016-08-29 01:54:49,347 INFO BlockStateChange (BlockManager.java:addToInvalidates(1228)) - BLOCK* addToInvalidates: blk_1073741825_1001 127.0.0.1:57662 127.0.0.1:43137 127.0.0.1:59637

          After stopping the last datanode, I can see the InvalidateBlocks size is 3.

          2016-08-29 01:54:49,350 INFO BlockStateChange (BlockManager.java:invalidateWorkForOneNode(3582)) - BLOCK* BlockManager: ask 127.0.0.1:59637 to delete [blk_1073741825_1001]

          Then the replication monitor woke up and removed one block from the invalidateBlocks set

          I think the test was checking the invalidateBlock size just after the replication monitor computed invalidate work for one node and that failed.
          I think stopping the replication monitor is the correct fix.

          Wei-Chiu Chuang, Zhe Zhang: Since you reviewed HDFS-9580, can you please help reviewing this patch.

          shahrs87 Rushabh S Shah added a comment -

          Forgot to mention +1 (non-binding)

          kihwal Kihwal Lee added a comment -

          The patch needs to be revised. BlockManagerTestUtil no longer has stopReplicationThread() method.

          ebadger Eric Badger added a comment -

          Attaching new patch for trunk. Looks like the replicationMonitor was renamed to the redundancyMonitor. The original patch works for branch-2, but uploading it as a branch-2 patch here for consistency.

          ebadger Eric Badger added a comment -

          Not sure why hadoopqa isn't running on the latest patches. Kihwal Lee, can you kick the hadoopqa bot?

          kihwal Kihwal Lee added a comment -

          Reattaching the trunk patch.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 18s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 6m 38s branch-2 passed
          +1 compile 0m 40s branch-2 passed with JDK v1.8.0_131
          +1 compile 0m 43s branch-2 passed with JDK v1.7.0_131
          +1 checkstyle 0m 27s branch-2 passed
          +1 mvnsite 0m 51s branch-2 passed
          +1 findbugs 1m 57s branch-2 passed
          +1 javadoc 0m 38s branch-2 passed with JDK v1.8.0_131
          +1 javadoc 0m 59s branch-2 passed with JDK v1.7.0_131
          +1 mvninstall 0m 43s the patch passed
          +1 compile 0m 37s the patch passed with JDK v1.8.0_131
          +1 javac 0m 37s the patch passed
          +1 compile 0m 41s the patch passed with JDK v1.7.0_131
          +1 javac 0m 41s the patch passed
          +1 checkstyle 0m 24s the patch passed
          +1 mvnsite 0m 49s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 2m 8s the patch passed
          +1 javadoc 0m 35s the patch passed with JDK v1.8.0_131
          +1 javadoc 0m 56s the patch passed with JDK v1.7.0_131
          -1 unit 50m 11s hadoop-hdfs in the patch failed with JDK v1.7.0_131.
          -1 asflicense 0m 19s The patch generated 1 ASF License warnings.
          126m 51s



          Reason Tests
          JDK v1.8.0_131 Timed out junit tests org.apache.hadoop.hdfs.server.datanode.TestDataNodeVolumeFailureReporting
          JDK v1.7.0_131 Failed junit tests hadoop.hdfs.server.datanode.metrics.TestDataNodeOutlierDetectionViaMetrics
            hadoop.hdfs.server.balancer.TestBalancerRPCDelay
            hadoop.hdfs.web.TestWebHDFS
            hadoop.hdfs.server.blockmanagement.TestReplicationPolicyWithUpgradeDomain



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:5e40efe
          JIRA Issue HDFS-10816
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12870804/HDFS-10816-branch-2.002.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux dc98d1d75698 3.13.0-106-generic #153-Ubuntu SMP Tue Dec 6 15:44:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision branch-2 / 2e8557d
          Default Java 1.7.0_131
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_131 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_131
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/19773/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs-jdk1.7.0_131.txt
          JDK v1.7.0_131 Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/19773/testReport/
          asflicense https://builds.apache.org/job/PreCommit-HDFS-Build/19773/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/19773/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 33s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 13m 56s trunk passed
          +1 compile 0m 46s trunk passed
          +1 checkstyle 0m 38s trunk passed
          +1 mvnsite 0m 55s trunk passed
          +1 findbugs 1m 43s trunk passed
          +1 javadoc 0m 43s trunk passed
          +1 mvninstall 0m 54s the patch passed
          +1 compile 0m 46s the patch passed
          +1 javac 0m 46s the patch passed
          +1 checkstyle 0m 36s the patch passed
          +1 mvnsite 0m 56s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 1m 48s the patch passed
          +1 javadoc 0m 40s the patch passed
          -1 unit 87m 49s hadoop-hdfs in the patch failed.
          +1 asflicense 0m 20s The patch does not generate ASF License warnings.
          114m 22s



          Reason Tests
          Failed junit tests hadoop.hdfs.TestDFSStripedInputStreamWithRandomECPolicy



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:14b5c93
          JIRA Issue HDFS-10816
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12871231/HDFS-10816.002.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 7e07d98ed317 3.13.0-116-generic #163-Ubuntu SMP Fri Mar 31 14:13:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 46f7e91
          Default Java 1.8.0_131
          findbugs v3.1.0-RC1
          unit https://builds.apache.org/job/PreCommit-HDFS-Build/19774/artifact/patchprocess/patch-unit-hadoop-hdfs-project_hadoop-hdfs.txt
          Test Results https://builds.apache.org/job/PreCommit-HDFS-Build/19774/testReport/
          modules C: hadoop-hdfs-project/hadoop-hdfs U: hadoop-hdfs-project/hadoop-hdfs
          Console output https://builds.apache.org/job/PreCommit-HDFS-Build/19774/console
          Powered by Apache Yetus 0.5.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          ebadger Eric Badger added a comment -

          Precommit test failures look unrelated

          kihwal Kihwal Lee added a comment -

          +1

          kihwal Kihwal Lee added a comment -

          I've committed this to trunk, branch-2 and branch-2.8. Thanks for analyzing and fixing the issue, Eric.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #11825 (See https://builds.apache.org/job/Hadoop-trunk-Commit/11825/)
          HDFS-10816. TestComputeInvalidateWork#testDatanodeReRegistration fails (kihwal: rev e4e203e0807fafc5dd765344d008e42bd51cc979)

          • (edit) hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/hdfs/server/blockmanagement/TestComputeInvalidateWork.java

            People

            • Assignee:
              ebadger Eric Badger
              Reporter:
              ebadger Eric Badger
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development