Uploaded image for project: 'Hadoop HDFS'
  1. Hadoop HDFS
  2. HDFS-10749

Log refactoring: method invocation should be replaced by variable

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Duplicate
    • 2.7.2
    • None
    • None
    • None

    Description

      Similar to the fix for HDFS-409. In file:

      hadoop-rel-release-2.7.2/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java

      In code block:

      lastQueuedSeqno = currentPacket.getSeqno();
      if (DFSClient.LOG.isDebugEnabled()) {
          DFSClient.LOG.debug("Queued packet " + currentPacket.getSeqno());
      }
      

      currentPacket.getSeqno() is better to be replaced by variable lastQueuedSeqno.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              chenfsd Nemo Chen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: