In code block:
currentPacket.getSeqno() is better to be replaced by variable lastQueuedSeqno.
in line 695, the logging code:
In the same class, there is a method in line 907:
We can tell that rpcServer.getRpcAddress() could be replaced by method getNameNodeAddress() for the case of readability and simplicity
in line 72, the logging code:
In the same class, there is a method in line 189:
We can tell that openFileMap.size() could be replaced by method size() for the case of readability and simplicity
Print variable in byte
Similar to the fix for
HBASE-623, in file:
In the following method, the log printed variable data (in byte). A possible fix is add Bytes.toString(data).
in line 76, the blk.getBlockName() method invocation is invoked on variable blk. "blk" is the class instance of Block.
In file: hadoop-rel-release-2.7.2/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/protocol/Block.java
The toString() method contain not only getBlockName() but also getGenerationStamp which may be helpful for debugging purpose. Therefore blk.getBlockName() can be replaced by blk