Details

    • Type: Umbrella Umbrella
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.94.0, 0.98.0, 0.95.0
    • Fix Version/s: 0.95.2
    • Component/s: None
    • Labels:
    • Release Note:
      HBase unit test now pass when run against hadoop2 (hadoop-2.0..5-alpha)

      Description

      An umbrella for all open issues for unit test failures specific to Hadoop 2.

        Issue Links

        1.
        TestImportExport on Hadoop 2 must copy YARN configuration vars Sub-task Closed Unassigned
         
        2.
        TestLocalHBaseCluster hangs with hadoop 2.0/0.23 builds. Sub-task Closed Himanshu Vashishtha
         
        3.
        TestImportExport has been failing against hadoop 0.23/2.0 profile Sub-task Closed Jonathan Hsieh
         
        4.
        TestImportExport tests failing due to jar manifest issues on Hadoop 2 Sub-task Resolved Jonathan Hsieh
         
        5.
        Fix hbase unit tests running on hadoop 2.0 Sub-task Resolved Jonathan Hsieh
         
        6.
        TestRowCounter consistently fails against hadoop-2.0 Sub-task Resolved Unassigned
         
        7.
        TestMiniClusterLoadSequential fails in trunk build on hadoop 2 Sub-task Closed Jonathan Hsieh
         
        8.
        TestJoinedScanners fails in trunk build on hadoop 2.0 Sub-task Closed Jonathan Hsieh
         
        9.
        TestDistributedLogSplitting#testThreeRSAbort fails against hadoop 2.0 Sub-task Closed Jonathan Hsieh
         
        10.
        Make mapreduce tests pass on hadoop2 Sub-task Resolved Jonathan Hsieh
         
        11.
        TestHFileOutputFormat.testMRIncremental* fails against hadoop2 profile Sub-task Closed Jonathan Hsieh
         
        12.
        TestTableInputFormatScan#testScanFromConfiguration fails on hadoop2 profile Sub-task Closed Jonathan Hsieh
         
        13.
        TestSecureLoadInc* tests hang repeatedly getting UnsupportedOperationException in hadoop2 profile Sub-task Closed Jonathan Hsieh
         
        14.
        TestLogRolling#TestLogRollOnDatanodeDeath hangs under hadoop2 profile Sub-task Closed Jonathan Hsieh
         
        15.
        Fix and reenable TestLogRolling.testLogRollOnPipelineRestart Sub-task Closed Enis Soztutar
         
        16.
        Investigate unit test performance regressions between hadoop1 and hadoop2 Sub-task Resolved Unassigned
         
        17.
        Investigate why disabling hadoop short circuit read is required to make recovery tests pass consistently under hadoop2 Sub-task Resolved Jonathan Hsieh
         
        18.
        TestMultiTableInputFormat hung in HBase-TRUNK-on-Hadoop-2.0.0 build #498 Sub-task Resolved Unassigned
         
        19.
        TestMetricMBeanBase#testGetAttribute is flakey under hadoop2 profile Sub-task Closed Elliott Clark
         
        20.
        Hadoop2 MR tests fail intermittently because of ArithmeticException in yarn nodemanager Sub-task Resolved Unassigned
         
        21.
        Hadoop2 MR tests fail with delete failing/hanging threads present Sub-task Resolved Unassigned
         
        22.
        TestImportExport failing again due to configuration issues Sub-task Closed Unassigned
         
        23.
        TestImportTsv failing due to configuration issues Sub-task Resolved Unassigned
         
        24.
        [hadoop2] TestTableInputFormatScan* fails intermittently with PrivilegedActionException Sub-task Closed Jonathan Hsieh
         
        25.
        HBASE-2231 breaks TestHRegion#testRecoveredEditsReplayCompaction under hadoop2 profile Sub-task Closed Enis Soztutar
         
        26.
        [hadoop2] Several tests break because of HDFS-4305 Sub-task Closed Jonathan Hsieh
         
        27.
        [hadoop2] TestMultiTableInputFormat always fails on hadoop with YARN-129 applied Sub-task Closed Jonathan Hsieh
         

          Activity

          ramkrishna.s.vasudevan added a comment -

          TestLocalHBaseCluster is hanging for us too with the same error.

          Jonathan Hsieh added a comment -

          Here's an updated list of failues for today's hbase trunk on hadoop 2.0.2-alpha, after the new HBASE-6330/HBASE-8528 patch gets applied to trunk. (all LargeTests)

          13:46:13  Results :
          13:46:13  
          13:46:13  Failed tests:   testMRIncrementalLoad(org.apache.hadoop.hbase.mapreduce.TestHFileOutputFormat)
          13:46:13    testMRIncrementalLoadWithSplit(org.apache.hadoop.hbase.mapreduce.TestHFileOutputFormat)
          13:46:13    testScanFromConfiguration(org.apache.hadoop.hbase.mapreduce.TestTableInputFormatScan)
          13:46:13  
          13:46:13  Tests in error: 
          13:46:13    testThreeRSAbort(org.apache.hadoop.hbase.master.TestDistributedLogSplitting): test timed out after 300000 milliseconds
          13:46:13    loadTest[0](org.apache.hadoop.hbase.util.TestMiniClusterLoadSequential): test timed out after 180000 milliseconds
          13:46:13    loadTest[1](org.apache.hadoop.hbase.util.TestMiniClusterLoadSequential): test timed out after 180000 milliseconds
          13:46:13    loadTest[0](org.apache.hadoop.hbase.util.TestMiniClusterLoadParallel): test timed out after 180000 milliseconds
          13:46:13    loadTest[1](org.apache.hadoop.hbase.util.TestMiniClusterLoadParallel): test timed out after 180000 milliseconds
          13:46:13    testJoinedScanners(org.apache.hadoop.hbase.regionserver.TestJoinedScanners): Failed 16 actions: NotServingRegionException: 16 times, 
          13:46:13  
          13:46:13  Tests run: 572, Failures: 3, Errors: 6, Skipped: 12
          13:46:13  
          
          Jonathan Hsieh added a comment - - edited

          trunk on Hadoop1 : 2503 unit tests [1]
          trunk on Hadoop2 : 2425 unit tests [2]

          78 tests missing!

          package hadoop1 hadoop 2 delta
          org.apache.hadoop.hbase 108 105 3
          org.apache.,hadoop.hbase.mapreduce 80 69 11
          org.apache.hadoop.hbase.regionserver 437 375 62
          org.apache.hadoop.hbase.regionserver.wal 116 114 2
          sum     78

          [1] https://builds.apache.org/job/HBase-TRUNK/4064/testReport/
          [2] https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-2.0.0/499/testReport/

          Ted Yu added a comment -

          One factor was that some tests hung (e.g. HBASE-8343), therefore not reported by Jenkins.

          Jonathan Hsieh added a comment -

          Missing tests in hadoop2

          org.apache.hadoop.hbase.TestDrainingServer
          org.apache.hadoop.hbase.TestGlobalMemStoreSize

          org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFiles
          org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFilesSplitRecovery

          org.apache.hadoop.hbase.regionserver.TestHRegion

          org.apache.hadoop.hbase.regionserver.wal.TestLogRolling

          Jonathan Hsieh added a comment - - edited

          I've run the set a few times locally under a hadoop2 profile. Looks like the last four have consistent hang while the first two timeout more transiently.

          
          -------------------------------------------------------
          Running org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFilesSplitRecovery
          Running org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFiles
          Running org.apache.hadoop.hbase.regionserver.wal.TestLogRolling
          Running org.apache.hadoop.hbase.regionserver.TestHRegion
          
          Running org.apache.hadoop.hbase.TestGlobalMemStoreSize
          Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 75.939 sec
          Running org.apache.hadoop.hbase.TestDrainingServer
          Tests run: 2, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 52.591 sec
          

          The TestSecureLoadInc* tests get an UnsupportedOperationExceptions until timeout that look like this:

          2013-04-15 14:03:50,311 ERROR [IPC Server handler 0 on 53755] access.SecureBulkLoadEndpoint$1(240): Failed to complete bulk load
          java.lang.UnsupportedOperationException: Immutable Configuration
                  at org.apache.hadoop.hbase.CompoundConfiguration.setClass(CompoundConfiguration.java:511)
                  at org.apache.hadoop.ipc.RPC.setProtocolEngine(RPC.java:193)
                  at org.apache.hadoop.hdfs.NameNodeProxies.createNNProxyWithClientProtocol(NameNodeProxies.java:249)
                  at org.apache.hadoop.hdfs.NameNodeProxies.createNonHAProxy(NameNodeProxies.java:168)
                  at org.apache.hadoop.hdfs.NameNodeProxies.createProxy(NameNodeProxies.java:129)
                  at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:409)
                  at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:376)
                  at org.apache.hadoop.hdfs.DistributedFileSystem.initialize(DistributedFileSystem.java:123)
                  at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:2296)
                  at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:85)
                  at org.apache.hadoop.fs.FileSystem$Cache.getInternal(FileSystem.java:2330)
                  at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:2312)
                  at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:316)
                  at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:162)
                  at org.apache.hadoop.hbase.security.access.SecureBulkLoadEndpoint$1.run(SecureBulkLoadEndpoint.java:224)
                  at org.apache.hadoop.hbase.security.access.SecureBulkLoadEndpoint$1.run(SecureBulkLoadEndpoint.java:218)
                  at java.security.AccessController.doPrivileged(Native Method)
                  at javax.security.auth.Subject.doAs(Subject.java:337)
                  at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1347)
                  at org.apache.hadoop.hbase.security.access.SecureBulkLoadEndpoint.secureBulkLoadHFiles(SecureBulkLoadEndpoint.java:218)
                  at org.apache.hadoop.hbase.protobuf.generated.SecureBulkLoadProtos$SecureBulkLoadService.callMethod(SecureBulkLoadProtos.java:3654)
                  at org.apache.hadoop.hbase.regionserver.HRegion.execService(HRegion.java:5024)
                  at org.apache.hadoop.hbase.regionserver.HRegionServer.execService(HRegionServer.java:3076)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                  at java.lang.reflect.Method.invoke(Method.java:597)
                  at org.apache.hadoop.hbase.ipc.ProtobufRpcServerEngine$Server.call(ProtobufRpcServerEngine.java:174)
                  at org.apache.hadoop.hbase.ipc.HBaseServer$Handler.run(HBaseServer.java:1871)
          
          
          Jonathan Hsieh added a comment -

          The unsupported operation exception is related to this exchange
          https://issues.apache.org/jira/browse/HBASE-7904?focusedCommentId=13617092&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-13617092

          I'll create a new issue for this specific problem

          Andrew Purtell added a comment -

          The "fix" for this problem on HBASE-7904 was unacceptable, FYI.

          Jonathan Hsieh added a comment -

          Another run shows the TestSecuireLoadInc* hanging the same way, TestLorRolling hanging but this time TestHRegion succeeds and TestDrainingServer has an error.

          -------------------------------------------------------
          Running org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFilesSplitRecovery
          Running org.apache.hadoop.hbase.mapreduce.TestSecureLoadIncrementalHFiles
          Running org.apache.hadoop.hbase.regionserver.wal.TestLogRolling
          
          
          Running org.apache.hadoop.hbase.regionserver.TestHRegion
          Tests run: 62, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 41.024 sec
          Running org.apache.hadoop.hbase.TestGlobalMemStoreSize
          Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 17.27 sec
          Running org.apache.hadoop.hbase.TestDrainingServer
          Tests run: 2, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 40.461 sec <<< FAILURE!
          
          Results :
          
          Tests in error: 
            testDrainingServerWithAbort(org.apache.hadoop.hbase.TestDrainingServer): test timed out after 30000 milliseconds
          
          
          Ted Yu added a comment -

          @Andy:
          How about the fix proposed in HBASE-8258 ?
          https://issues.apache.org/jira/secure/attachment/12577283/8258-v4-hadoop-2.0.txt

          Namely, in SecureBulkLoadEndpoint.java:

          -      fs = FileSystem.get(conf);
          +      fs = FileSystem.get(new HBaseConfiguration(conf));
          
          Andrew Purtell added a comment -

          How about the fix proposed in HBASE-8258

          Fine, if it works.

          Jonathan Hsieh added a comment -

          Ted Yu, Andrew Purtell, I've filed a new issues specfiically for the TestSecureLoadincremental* failures here HBASE-8347. Ted, howabout you post your patch and the explanation of why it is the fix there?

          Jonathan Hsieh added a comment -

          After fixing HBASE-8347, I did a comparison and have 14 sometimes hanging tests (as well as a few flakeys)

          So here is where we are now:

          package hadoop1 hadoop 2 delta
          total 2509 2495 14
          org.apache.hadoop.hbase.mapreduce 80 66 14
          sum     14

          Here's the current set of sometimes hanging tests:
          org.apache.hadoop.hbase.mapreduce:

          • TestMultiTableInputFormat 5
          • TestMultithreadedTableMapper 1
          • TestRowCounter 3
          • TestTableInputFormatScan1 5

          Classes#method Flakies (that didn't hang)

          • TestHFileOutputFormat#testExcludeAllFromMinorcompaction
          • TestimportExport#testWithFilter
          • TestImportTsv#testBulkOutputWithoutAnExistingTable, #testMROnTable
          • TestTableInputFormatScan2#testScanYYXToEmpty
          • testTableMapReduce#testMultiRegionTable
          Jonathan Hsieh added a comment -

          The flakey tests have logs that seem to fit in two categories. I've file jiras for the two categories:

          • HBASE-8417: ArithmeticExcpetion bug in Hadoop2. TestHFileOutputFormat#testExcludeAllFromMinorcompaction, TestTableMapReduce#testMultiRegionTable
          • HBASE-8419: hanging threads/unable to delete TestImportExport.testWithFilter, TestImportTsv#testBulkOutputWithoutAnExistingTable
          Hudson added a comment -

          Integrated in HBase-0.94-security #169 (See https://builds.apache.org/job/HBase-0.94-security/169/)
          HBASE-6891 TestImportExport failing again due to configuration issues (Revision 1494257)

          Result = FAILURE
          stack :
          Files :

          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/mapreduce/TestImportExport.java
          Hudson added a comment -

          Integrated in HBase-0.94 #1014 (See https://builds.apache.org/job/HBase-0.94/1014/)
          HBASE-6891 TestImportExport failing again due to configuration issues (Revision 1494257)

          Result = FAILURE
          stack :
          Files :

          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/branches/0.94/src/test/java/org/apache/hadoop/hbase/mapreduce/TestImportExport.java
          Hudson added a comment -

          Integrated in HBase-TRUNK #4184 (See https://builds.apache.org/job/HBase-TRUNK/4184/)
          HBASE-6891 TestImportExport failing again due to configuration issues (Revision 1494256)

          Result = SUCCESS
          stack :
          Files :

          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestImportExport.java
          Hudson added a comment -

          Integrated in hbase-0.95 #246 (See https://builds.apache.org/job/hbase-0.95/246/)
          HBASE-6891 TestImportExport failing again due to configuration issues (Revision 1494266)

          Result = FAILURE
          stack :
          Files :

          • /hbase/branches/0.95/hbase-server/src/test/java/org/apache/hadoop/hbase/HBaseTestingUtility.java
          • /hbase/branches/0.95/hbase-server/src/test/java/org/apache/hadoop/hbase/mapreduce/TestImportExport.java
          stack added a comment -

          Resolving as basically fixed by Jon's and the work of others. See recent build box successes for justification for resolution. Will open more specific issues as we see h2 problems going forward.


            People

            • Assignee:
              Jonathan Hsieh
              Reporter:
              Andrew Purtell
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development