Uploaded image for project: 'HBase'
  1. HBase
  2. HBASE-20501

Change the Hadoop minimum version to 2.7.1

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Hadoop Flags:
      Incompatible change
    • Release Note:
      Hide
      <!-- markdown -->
      HBase is no longer able to maintain compatibility with Apache Hadoop versions that are no longer receiving updates. This release raises the minimum supported version to Hadoop 2.7.1. Downstream users are strongly advised to upgrade to the latest Hadoop 2.7 maintenance release.

      Downstream users of earlier HBase versions are similarly advised to upgrade to Hadoop 2.7.1+. When doing so, it is especially important to follow the guidance from [the HBase Reference Guide's Hadoop section](http://hbase.apache.org/book.html#hadoop) on replacing the Hadoop artifacts bundled with HBase.
      Show
      <!-- markdown --> HBase is no longer able to maintain compatibility with Apache Hadoop versions that are no longer receiving updates. This release raises the minimum supported version to Hadoop 2.7.1. Downstream users are strongly advised to upgrade to the latest Hadoop 2.7 maintenance release. Downstream users of earlier HBase versions are similarly advised to upgrade to Hadoop 2.7.1+. When doing so, it is especially important to follow the guidance from [the HBase Reference Guide's Hadoop section]( http://hbase.apache.org/book.html#hadoop ) on replacing the Hadoop artifacts bundled with HBase.

      Description

      See discussion thread on dev@ "[DISCUSS] Branching for HBase 1.5 and Hadoop minimum version update (to 2.7)"

      Consensus

      • This is a needed change due to the practicalities of having Hadoop as a dependency
      • Let's move up the minimum supported version of Hadoop to 2.7.1.
      • Update documentation (support matrix, compatibility discussion) to call this out.
      • Be sure to call out this change in the release notes.
      • Take the opportunity to remind users about our callout "Replace the Hadoop Bundled With HBase!" recommending users upgrade their Hadoop if < 2.7.1.

        Attachments

        1. HBASE-20501.0.patch
          6 kB
          Sean Busbey

        Issue Links

          Activity

            People

            • Assignee:
              busbey Sean Busbey
              Reporter:
              apurtell Andrew Kyle Purtell

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment